INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

Application Error - IWR

Application Error - IWR

(OP)
hi

i created a Imp.report and published from Report Publishing, publishing was successfull.
But from the upfront, when i tried to access it, its giving the below error message:


Application Error
The report request failed.
The execution of this report at 2147483649/2147483648/2147485548 2147483648:2147483648:2147483648 failed due to the following reason:
Unable to execute report D:\Upfront\Test\apps\Report1.imr. Reason: Error: 0, Generic; Process ID: 2424; Thread: 5204; Host: DEVSERVER1040; Text: Unexpected Error in ExecuteRunReport. Please contact your System Administrator. Report: D:\Upfront\Test\apps\Report1.imr; BackTrace Info: .



The catalog is built on the Oracle database. I created another report based on a catalog (MS Access database) and it works with same way of publishing.

Is it because of Oracle Username and Password security? If yes, where to specify that?

In Access manager, I have added the database and signon, updated that for the user. what else is missing???

Report runs fine from the Imp.Client.

thanks and regards,
Sudhi

RE: Application Error - IWR

(OP)
its me again,

i resolved this, found a solution in this forum.

i updated the catalog with database connection details. its working.

thanks.

sudhi

RE: Application Error - IWR

Hi,

I'm getting exactly the same error, but my catalog already has the correct database connection string. All other reports in the same reportset run ok in Upfront.
The .imr report in question works fine in impromptu.
I'm connecting to an Oracle 8i backend aswell.
Any ideas?

Thanks

Ronnybiggs

RE: Application Error - IWR

Are you able to run the report with the client version of Impromptu that is installed on the server that is running IWR?  Make sure that the server machine is able to connect to the database.

RE: Application Error - IWR

scost,

I ran the .imr report in Impromptu windows client on the server and no problem ... the server is connecting to the DB ok. The web report still complains though. Any ideas what else to try?

Thanks,

ronnybiggs

RE: Application Error - IWR

Hi,

Just for the record, I figured out why my report won't run in Upfront. My report , ReportB.imr is calling another report, ReportA.imr
ReportA.imr calls a stored procedure which takes a single type-in parameter -  Date.
ReportB.imr takes two parameters,  Date (Type in) and Portfolio ID (Number, Catalog picklist).
The Portfolio Id prompt is invoked in the Filter clause of the reportB.imr, using the IN keyword so that multiple selections can be made. The reason I did this is that I couldn't figure out a way of passing multiple selections of a prompt into a Stored Proc, so I figured I'd take all Portfolios for a given date in the Stored Proc then filter out the ones we wanted in ReportB.imr.
This works fine in Impromptu Windows client, but it all goes pear shaped in Upfront - it tries to pass both prompts from ReportB to the stored proc instead of just one.
Can't think of any solution, so i might try getting powerprompts to invoke the Stored Proc to write to a temporary table, and then launch a report that reads the table ....  unless anyone out there has a more dignified solution?

Thanks,

Ronnybiggs

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close