INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Gentran Extended Rules Mapping Error

Gentran Extended Rules Mapping Error

(OP)
I am running Gentran 5.3 on Windows 2000 and am making an import map for 856 EDI from a flat file.

I am hard coding a qualifier on the output side of the map in the N103 segment of the Shipment Level, but when I run data through the translation object, Gentran puts the hard coded qualifier in the N102 segment. I have double checked to make sure the correct element is listed in the extended rules.

Here is the ext rule for N103 ID Code Qualifier (field 0066):
#0066="92";

That is it, don't know how it gets in N102 Name (field 0093).

Anyone had a similar problem? Is it a bug in the Gentran Software?

RE: Gentran Extended Rules Mapping Error

Hi kclark747,
I don't have the solution for you, but i guess like it always is with extended rules, that the rule should be written in another way, do you have a manual for extended rules, look in that.

RE: Gentran Extended Rules Mapping Error

(OP)
Thanks for the reply gplay666.
As to writing the extended rule another way,
#0066="92";  is the entire extended rule.
What I ended up doing was deleting the N1 group that this was occuring on and creating a new group. The new group does not have the same problem.
It looks more like there was some glitch in the Gentran software.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close