Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

blisten (TechnicalUser)
8 Jul 03 15:53
I am looking to put Peachtree 2004 on a windows 2000 terminal server.  I currently have 2003 working, although it is not support, has anyone figure out any reg hacks for 2004?

Bob Listen
A+ MCP CCA

scotchneat4me (MIS)
3 Sep 03 0:05
The ini file you need to copy to the c:\documents and settings\'user'\windows file is ppa*.ini, if you are running peacthree premium accounting.

follow the steps in http://dev.remotenetworktechnology.com/ts/peachtree.htm

Seems to work fine for me
Cbryan (MIS)
15 Sep 03 18:08
I tried the stuff that was in that doc. I still could get 2004 to work on our windows 2000 terminal server. I keep getting the message that peachtree was unable to detect the status of the peachtree.ini. If anyone has any input I would appreciate it..

kjf1973 (TechnicalUser)
4 Oct 03 19:48
Has anyone been able to make this work?
Parrothead928 (IS/IT--Management)
9 Oct 03 11:17
Yes I got Peachtree 2004 to run on terminal server. (citrix)Very simple actually. Find HKLM\System\CurrentControlSet\Control\TerminalServer\TSAppCompat in the registry editor.  Then change the value from a one to a zero.   This has worked for me on my test server.  Have not implememted it to my production server yet.  So far this tweek has had no negative reprocussions.  I'm going to restrict Peachtree 2004 to my test machine until I figure out how to make it allow more than one instance to run.  THIS is what I need help with..  Anyone have any luck.  please respond or email me at jcroeder@procopy.com
Parrothead928 (IS/IT--Management)
10 Nov 03 10:20
Update to my previous post...  Please test this registry tweek extensively, It was reported to me that this tweek has caused unwanted results with TS licensing.
worstkidever (MIS)
11 Nov 03 20:45
Do you have any specific info on the kind of TS licensing problems that registry change causes?  I'm working on the same thing at a client's site tomorrow.
fortress22 (MIS)
23 Nov 03 5:55
I'm also trying to run peachtree 2004 on win2k terminal server. Has any one been able to do this? Thanks
Helpful Member!  1985ramcharger (TechnicalUser)
24 Nov 03 8:38
WARNING!!! Changing the TSAppCompat reg key from 1 to 0 will work for one user, but if you have to reboot, your terminal server will change from Application Mode to Remote Admin mode.  This will disable your ability to run published applications.  I am currently rebuilding my Citrix server, so test it first.  Any help is appreciated.
1985ramcharger (TechnicalUser)
24 Nov 03 10:36
GOT IT TO WORK WITH NO REGISTRY MODS.  Here is the file I wrote.

Running Peachtree 2004 in a Citrix Environment (unauthourized by Peachtree.  Use at your own risk)

Please note, changing the HKLM\System\CurrentControlSet\Control\TerminalServer\TSAppCompat registry key from 1 to 0 will allow peachtree to run, however, when you reboot, the server will come up in Remote Admin mode and render your Citrix / TS environment USELESS. The licensing issues reported above are a direct result of running your Terminal Server in Remote Admin mode which limits you to two users max.  The following steps will allow you to run Peachtree and remain in Application Mode, thus preserving your Citrix Terminal Server Environment. This method does not require ANY registry modifications.

1. Copy the following files from the C:/winnt folder on your Citrix / Terminal Server to the the C:\Documents and
Settings\%username%\Windows folder:
    pcw110.ini (this file may vary based on version)
    bti.ini

2. Copy the following files from the \Peachw installation folder on your Citrix / Terminal Server to the C:\Documents and Settings\Username\Windows folder:
    MKDEWE.TRN
    MKDEMSG.LOG

3. Edit the BTI.ini file.  Change the "trnfile=" value from the default to "%HOMEDRIVE%%HOMEPATH%\WINDOWS\" without the quotes and save the file.

4. Verify that the %HOMEDRIVE%%HOMEPATH%\WINDOWS\ path is correct by copying it to the run prompt and select "OK".

When the window opens up, it should be the windows directory for the specified user.  If this does not display, then you will either need to modify the path to not use variables as shown above, or check to see if you are using a Home Directory in the user's profile as this will interfere with the ability to use variable data.  The benefit of using the variable data is that you can copy the same BTI.ini file to all users without having to customize on a per user basis.

Good Luck.
1985ramcharger (TechnicalUser)
24 Nov 03 10:38
One additional note. This is a Win2k Server with SP4 running Citrix MF XP with FR3.  The program is still limited to one user at a time.
jim2kmcse (TechnicalUser)
9 Dec 03 15:28
Is there any way to get around the one user session limit?
fortress22 (MIS)
12 Dec 03 2:35
Hi Blisten,

Can you share with us how you got peachtree 2003 to work on terminal server? I trying to do on my terminal server. Thanks.
blisten (TechnicalUser)
6 Jan 04 14:57
I have been successful since my post, Useing the website given by scotchneat4me.  No problems since i installed in september

Bob Listen
A+ MCP CCA

Helpful Member!  lebisol (IS/IT--Management)
16 Jan 04 21:59
what is the point if u get only 1 user to use the PT remotly?
might as well use VNC or some other free gizmo!

my test so far:
-PT 2004 Compleate
-win2000 with TS in Remote Admin Mode
ALL based on the http://dev.remotenetworktechnology.com/ts/peachtree.htm

results:
does NOT work but only for the ADMIN account and can NOT accept the additional (2nd and the last) concurrent admin OR user account as PT refuses to run while the other accunt is using it.


I will give it shoot in Application Mode....although I have my doubts......Citrix is a whole another deal.
Have any of you tried setting up "VPN mapped drive" to datasource on remote location!?
Thanx for sharing.......
the battle continues....as I grow more gray hair over PT
All the best!

> need more info?
:: don't click HERE ::

lebisol (IS/IT--Management)
16 Jan 04 23:26

2nd round:
my test so far:
-PT 2004 Compleate
-win2000 server with TS in App Mode
ALL based on the http://dev.remotenetworktechnology.com/ts/peachtree.htm
-----------------------------------------------------------
2 concurrent users so far

1st test failed for the resons desicribed....voulme mounted to TS user folder was dropped upon reboot....
this was not the case for the TS in App Mode.
Running PT Semi-Live Updates from the TS Client did not work.
Now...the real question is WHY PT team does not make this a standard feature vs. tweaking the registry?
Sessions are no longer the issue.
The only other thing I can think of as a possible danger in data corruption is in WebSynch or TS sessions

Anyow, the link provided worked for PT2004 Compleate as well....all it is left is hope that PT some days develps this furter as they """Remote Data Access"""" over the web is a joke and offers only 5% of the functions that entire app has.
All the best!

> need more info?
:: don't click HERE ::

jrpolgar (TechnicalUser)
29 Feb 04 10:22
I think I fixed it.
I had 2003 pt running on ms server 2003, network setup as peer to peer.  Other 3 computers used it, however, only one person could use at a time if using the app on server.  App on workstations and data path to server there were no problems.

I just got in multiuser peachtree complete 2004.  Followed all the instructions.  It worked fine but only when "open peachtree" was selected at end of install.  Once peachtree closed I could not open again.  "Peachtree could not detect the status of peachtree ini."

Several removes, reinstalls, and following every thread in pt knowledge base and this thread plus links I couldn't get it to open no matter what I did.

Finally, I did a search for pcw*.ini and found that the 2003 version pcw100.ini was located in the windows root AND the Administrator/Documents and settings/windows folder.  So I copied the pcw110.ini (2004 version) from the windows root into the same folder as the pcw100 in admin and it worked!

Don't know if there will be other issues later since I wanted to install and get it to work on server first.  Then I'll load on work stations.  Seems this ini file may need to be copied into each users windows folder.

Will post more and certainly ask more if other problems develop.  I'm not a programmer or much of a tech person.  I own my business and have a systems admin help with tech problems.  Usually he fixes what I mess up   But I do follow logical analysis to trace problems and find solutions which at least get me functional until it's fixed tight or I stumble upon a "right" fix.  I'd be happy to answer any questions but just remember I am not REAL up on a lot of nomenclature you real techs might use.  THANKS FOR THIS THREAD!  It was information in here on similar issues that helped me find the solution for pt2004 and ms windows server 2003 enterprise edition.
lebisol (IS/IT--Management)
1 Mar 04 12:21
"Seems this ini file may need to be copied into each users windows folder."
It is a must!

> need more info?
:: don't click HERE ::

tracydfl (MIS)
30 Apr 04 15:35
I've read all the posts here and have a question. I have window 2003 small business server. Loaded PT 2004. It runs fine for the administrator account (account used to install it. I have Terminal Server installed in application mode and use the remote desktop application to connect to the server. And I read where I was supposed to copy the pcw110.ini file into the windows directory for the users. But when I check the directories, they don't have a windows directory. I'm sure I'm missing something. Can someone please point me in the right direction? I get the error "currently, another user has Peachtree Accounting Open on this computer....." Is there a work around?
mac9 (IS/IT--Management)
30 Apr 04 16:28
I have PeachTree Complete 2002 running on a Win2k TS with Citrix Metaframe. The only way I was able configure multi-user access into a single company was to install seperate copies of Peachtree.  Since the user list for Peachtree was short, only 3 people, this didn't over burden the TS.
I have tested PCA 2004, but not in multi-user yet.

There is a compatiblity script in Win2k that sets up the W:\ drive for c:\doc..\username\windows (or something like that?)

Michael
lebisol (IS/IT--Management)
2 May 04 21:24
follow the links given...
ALL based on the http://dev.remotenetworktechnology.com/ts/peachtree.htm
make sure u install PT while in Install mode on TerminalServer...

> need more info?
:: don't click HERE ::

pdisenso (IS/IT--Management)
23 Jun 04 13:24
Has anyone figured out how to get PT 2004 to work, multi user, under Citrix.  We can get it to work, but only for one user.  Help please...
lebisol (IS/IT--Management)
23 Jun 04 14:00
Hi mac9!
"There is a compatiblity script in Win2k that sets up the W:\ drive for c:\doc..\username\windows (or something like that?)"


yes,
"RootDrv2.cmd" file located in folder:
C:\WINNT\Application Compatibility Scripts\

======================================================

tracydfl
"And I read where I was supposed to copy the pcw110.ini file into the windows directory for the users. But when I check the directories, they don't have a windows directory. I'm sure I'm missing something. "

this sets Variables NOT the ACTUAL user's directory folder where one must copy the 'PWx.ini' file.
...this file still resides (needs to be copied to) in users default folder that is 'self-created' AFTER successful login into TS and BEFORE you even begin PT install from Admin account...which is:
c:\documents and settings\[login name]\windows
...THE SAME structure as if your users were just login into your Domain (server)
=================
http://dev.remotenetworktechnology.com/ts/peachtree.htm
has all the steps but you ******MUST***** compleate every step in order....
All the best!

:--------------------------------------------------------------------------:

 ok,ok...I did shoot the deputy but he told me he was the sheriff!
:--------------------------------------------------------------------------:

Helpful Member!(2)  tylan (TechnicalUser)
25 Jun 04 11:41
Has anyone figured out the multi-user thing yet?  It seems to work with one TS user, but I can't get a second terminal session to open Peachtree.  Ideas?

Tylan
- Who prohibits the use of an application on Terminal Server?!?!?
lebisol (IS/IT--Management)
25 Jun 04 12:19
ok, I give up on pasting the link....

:--------------------------------------------------------------------------:

 ok,ok...I did shoot the deputy but he told me he was the sheriff!
:--------------------------------------------------------------------------:

mac9 (IS/IT--Management)
30 Jun 04 17:54
OK, I'll post the link for you Lebisol.
http://dev.remotenetworktechnology.com/ts/peachtree.htm

This works for Peachtree Complete 2004 MULTI-USER on Windows 2003 / Citrix Metaframe XP SP3

Tylan - Are you getting a specific error?

mac

Michael Chase
Senior IS Manager

tylan (TechnicalUser)
30 Jun 04 19:29
I can't remember, but It would only let one copy open at a time.  IE--> One at the console, but nowhere else.  One thru TS session, but nowhere else.  We are using Peach 2004.
kjf1973 (TechnicalUser)
1 Jul 04 14:36
TS can not be in Administration mode.  Needs to be in app mode.  
tylan (TechnicalUser)
2 Jul 04 15:57
We were in App mode.  Still would only let one copy open at at time.

We followed all the steps in this article:
http://dev.remotenetworktechnology.com/ts/peachtree.htm

Are you sure this article allows peachtree to open for more than one terminal  session at once? I couldn't even open peachtree before doing the steps in that article.

We eventually copied the peachtree folder to each users profiles, and pointed a few reg entries to the %userprofile% path for the program location.  It works perfect now.  Do you think we skipped a step?

I saw on an earlier post that pdisenso had the same problem.
robul (IS/IT--Management)
8 Jul 04 17:06
Any help would be great on this matter.

We recently upgraded from peachtree 2003 to 2005.

I have followed every step to make it so every terminal server client can logon. Although only 1 user can logon at a time.

Any suggestions to resolve this problem? I need to have about 5 users logged on at the same time. We even purchased the peachtree 2005 version for multiple users but I guess what is happening is the server thinks there is instances of peachtree allready running and will not start an additional one.

any help would be awesome.

Also I am running the terminal server in app mode

robert6165 (MIS)
27 Jul 04 14:40
Same problem here. We have multi-user version of Peachtree Premium accounting, I also followed all the steps but can only open 1 session at a time. Does anyone actually (production tested) have a way to get multiple sessions running at one time with no problems\errors etc..
blisten (TechnicalUser)
27 Jul 04 16:30
I have now succesfully run 2004 and 2005 in terminal server production environment for over a year now, follow the intsructions word for word or it will not work.

Bob Listen
A+ MCP CCA

robert6165 (MIS)
27 Jul 04 17:47
Bob, that means multiple user/sessions right ? Using these instructions ?

http://dev.remotenetworktechnology.com/ts/peachtree.htm which are for version 8/9 ?

Thanks
blisten (TechnicalUser)
27 Jul 04 19:16
correct, you need to make sure that you map the W:\ drive, or what ever their homedrive is.  Then copy the files mentioned in those directory, for peachtree 2005, the file name is different, but you cna see what files need to be moved.  I have peachtree running in a citrix environment for a local high school that uses it for an accounting class.  so 25 users per hour for 6 hours and no problems.

Bob Listen
A+ MCP CCA

robul (IS/IT--Management)
10 Aug 04 16:18
Tylan do you think you can help us out and tell us what reg entrys you had to point to make it work?

thanks
mac9 (IS/IT--Management)
10 Aug 04 16:44
Firstly, I have two Citrix servers (Windows 2000 and W2k3) running Ptree version 2002 and 2004, both in multi-user mode.  As I read Bob's post about 25 users in a classroom setting, it accured to me that my users (and maybe Bob's) are setup as local accounts (not domain users) on the terminal servers.  
Perhaps the difference between those of us who have multi-user working and those who continue to have only single user, is a local/domain user issue.

Any thoughts?
mac

Michael Chase
Senior IS Manager

blisten (TechnicalUser)
10 Aug 04 17:11
my users are running in Active directory

Bob Listen
A+ MCP CCA

CHarmon (MIS)
11 Aug 04 14:21
I was looking at the instructions from http://dev.remotenetworktechnology.com/ts/peachtree.htm and was wondering if you used the REL7REG.REG file. If so, where can I get a copy? I'm trying to setup Peachtree Complete 2004 on a 2003 SBS Terminal server for an accountant with remote clients and employees.
tylan (TechnicalUser)
11 Aug 04 14:25
Robul,
Here is the key that was our trouble maker.  We were running PT2004, and now we are running PT2005.  I'm not sure if this still key is still used.

[HKEY_LOCAL_MACHINE\SOFTWARE\Btrieve Technologies\Microkernel Workstation Engine\Version  6.15\Settings]
"Home Directory"="D:\\PROGRA~1\\PEACHT~1\\"

Our friend who helped us out made that key point to
%userporfile%\PT\.  I don't think we used anything on the W: drive at all.  The only issue with this method is that each TS user has to have a copy of PT in thier profile.

Our friend used regmon and filemon (from www.sysinternals.com) to see what reg key was causing problems.  Then you can use a system variable to correct it.

Hope this helps.
tylan (TechnicalUser)
17 Nov 04 11:04
I know this thread has been inactive for a while but...

I have PT on a 2003 TS, works fine.  I just cant figure out why it takes a while to close out our company (20 secs) if anyone else is in the company.  If a TS user is the only person in, the company closes nice and quick!  All the local LAN clients close fine no matter what.

Thanks Guys...

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close