INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

error 20997 when running an application that calls a CR

error 20997 when running an application that calls a CR

(OP)
Hi!

when I click on the application and then select which report I want to run. The report seems to open but then it shows a blank page and an error message saying ERROR 20997:????

In other machines the report works fine, in this particular machine it used to work fine but no it doesn't anymore.

I am using CR 8.5 and VB.

Can somebody please help? Thanks in advanced!!! :)

RE: error 20997 when running an application that calls a CR

A generic error.

I'd guess that some DLL is missing or not registered now.

Search the CD knowledgebase for various articles on this.

http://support.crystaldecisions.com/

-k

RE: error 20997 when running an application that calls a CR

(OP)
We already tried all the kbases from their website but to no avail.

Any other ideas? I even used modules to find some dll missing but nothing.

Thanks!

RE: error 20997 when running an application that calls a CR

This suggests that something changed on that one machine, perhaps a DLL was crushed/replaced, or there's a bad/missing registry setting.

Lots of programs use Crystal as the reporting engine, a different version might cause this.

-k

RE: error 20997 when running an application that calls a CR

(OP)
thank you! It is still not working.

RE: error 20997 when running an application that calls a CR

Given you have one machine that is currently working and one that is failing, you have the answer right there.

As synapsevampire suggested something has certainly changed on this machine and you need to debug.

Fortunately for you in this case, there is a tool that will save a bunch of time.  Here is a link --

http://support.crystaldecisions.com/communityCS/FilesAndUpdates/modules.zip.asp

Check the help file, but this is pretty intuitive to use.

Cheers,

SurfingGecko
http://www.surfinggeckosoftware.com

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close