Member Login

Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

CrystalEnterprise Logon JSP

CrystalEnterprise Logon JSP


I installed Crystal Reports 8.5 in Windows 2000.
For viewing reports using Java viewer,i tried to login using the Crystal Enterprise SDK API.
The method i am calling is
CrystalEnterprise..getSessionMgr().logon(username, password, apsName, apsAuthType);

Though i am giving the correct values for username,password,apsName and apsAuthType,it
is giving the following error and i am unable to logon:

'com.crystaldecisions.sdk.exception.SDKException$OCAFramework: Communication error occurred when trying to connect

to server
cause:com.crystaldecisions.enterprise.ocaframework.OCAFrameworkException$CommunicationError: Communication error

occurred when trying to connect to server minor code: 0x0 completed: No detail:Communication

error occurred when trying to connect to server
 The exception originally thrown was minor code: 0x0

completed: No detail:Communication '

Pls note that i am able to logon with the same values thro'  the 'Crystal Publishing Wizard'.
I am getting this error only when i tried to logon using JSP.

The following are enabled running:
Crystal APS
Crystal Cache Server
Crystal Input Repository Server
Crystal Output Repository Server
Crystal Page Server
Crystal Report Job Server
Crystal Web Component Server

If anyone knows the solution, please let me know.


RE: CrystalEnterprise Logon JSP

I've been getting the same problem as well. Did you ever get it solved? Does anyone have any idea

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close