INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Newbie needs help: Amanda, HP SureStore 24x6, amlabel error

Newbie needs help: Amanda, HP SureStore 24x6, amlabel error

(OP)
Hi,

I am a newbie to Amanda. I have set up version 2.4.2.p2 on a RedHat
Linux 7.3 system with a HP SureStore 24x6 external drive (HP C1557A).
Installation of amanda went on fine. Here are relevant portions from
the amanda.conf file :

**********************************************************

runtapes 1        # number of tapes to be used in a single run of amdump
tpchanger "/etc/amanda/daily/chg-zd-mtx"    # the tape-changer glue
script
tapedev "/dev/nst0"    # the no-rewind tape device to be used
rawtapedev "/dev/nst0"    # the raw device to be used (ftape only)
changerfile "/etc/amanda/mtx-changer"
#changerfile "/usr/adm/amanda/daily/changer-status"
#changerfile "/etc/amanda/daily/changer.conf"
changerdev "/dev/sgb"

tapetype HP1557A        # what kind of tape it is (see tapetypes below)
labelstr "^DailySet1-[0-9][0-9][0-9]"    # label constraint regex: all
tapes must match

[....]

define tapetype HP1557A {
    comment "HP SureStore DAT24x6e tape drive"
    # data provided by Ivo Clarysse
    length 12000 mbytes
    filemark 111 kbytes
    speed 3000 kbytes
}


*********************************************************

I have tried using the mtx-changer command, and can eject and load
individual tapes using it. However, when after all configuration was
done, and I wanted to label a tape using the command:

su amanda -c "amlabel daily DailySet1"

I get this error:

*********************************************************************

labeling tape in slot /etc/amanda/daily/chg-zd-mtx: ([: too many
arguments):
rewinding
amlabel: no tape online


*********************************************************************

I used info from this URL for tape changer configuration :
http://www.soti.org/~soggie/linux/hw/hp-surestore-24x6/

And for other Amanda installation and general configuration, I
followed the guide at:

http://www.frankenlinux.com/guides/amandaserver.html

I have also tested my tape drive using tar commands, and it works well
 with the device file /dev/nst0. The changer device file shows up as
/dev/sg1.

Here is the output of the mt status command:

**********************************************************************

SCSI 2 tape drive:
File number=0, block number=0, partition=0
Tape block size 0 bytes. Density code 0x25 (DDS-3).
Soft error count since last status=0
General status bits on (41010000):
 BOT ONLINE IM_REP_EN


**********************************************************************

Any help in resolving this problem will be much appreciated!

Thanks,
Vivek

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close