INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

/usr/ucb/cc: language optional software package not installed

Share

/usr/ucb/cc: language optional software package not installed

/usr/ucb/cc: language optional software package not installed

(OP)
I am getting this message when I try to run a make on the Tk perl module.

I have gcc installed, the path to gcc is before the path to cc in my $PATH variable, I have created a symbolic link from cc to gcc and I have set my env variable CC=gcc. I have tried all the above in different permutations and varieties and have searched the web FAQ on this forum and this forum itself before I posted this. I am running Solaris 2.8 on a Sparc5. I am untaring the distribution in the /temp direcotry and running everything from there.

The install says to:

perl Makefile.PL  (runs fine, no errors)
make              (bombs with the eror mentioned)

I am at my wits end and ready to reinstall everything from Solaris up but do not want to waste 2 or 3 days doing this.

Please help.

RE: /usr/ucb/cc: language optional software package not installed

(OP)
I checked the cc script and it seems that this is the default error message if /usr/ccs/bin/ucbcc does not exist, and on my computer it does not!

What is /usr/ccs/bin/ucbcc and where do I get it?

RE: /usr/ucb/cc: language optional software package not installed

Hi
This will work ok if you link ucbcc to your gcc command.
For example, if you installed gcc into /usr/local, then the
gcc command will be in /usr/local/bin.
ln -s /usr/local/bin/gcc /usr/ccs/bin/ucbcc
Then if you have /usr/ucb in your path, you can use the cc
command.
Good luck
John

John Philcox
Mobile Ventures Limited UK
http://www.mobile-ventures.net

RE: /usr/ucb/cc: language optional software package not installed

(OP)
Thanks for the reply jephilc, I tried that. Now I get the following error messages.

cc -c -I.. -I/usr/openwin/include -I. -Ibitmaps -I/usr/openwin/include  -xO3 -xdepend     -DVERSION=\"800.024\"  -DXS_VERSION=\"800.024\" -KPIC -I/usr/perl5/5.00503/sun4-solaris/CORE   tkUnixMenubu.c
ucbcc: unrecognized option `-Xs'
ucbcc: unrecognized option `-KPIC'
ucbcc: language depend not recognized
ucbcc: tkUnixMenubu.c: linker input file unused since linking not done
ucbcc: -lucb: linker input file unused since linking not done
ucbcc: -lsocket: linker input file unused since linking not done
ucbcc: -lnsl: linker input file unused since linking not done
ucbcc: -lelf: linker input file unused since linking not done
ucbcc: -laio: linker input file unused since linking not done


Any ideas anyone?

RE: /usr/ucb/cc: language optional software package not installed

You've already done all I would have suggested. Where did you get gcc? Did you get it from sunfreeware? If not, try theirs, maybe the pkgadd command sets some enviromental stuff for you. You definitely don't need to re-install the OS.

RE: /usr/ucb/cc: language optional software package not installed

Rename the /usr/ccs/bin/cc file and force ur system to take GCC as default compiler.
/usr/ccs/bin/cc inturn calls ucbcc and thats why u r getting this error.
Even if u hav updated the path variable, the cc is being called somehow. so try removing those traces.

Regds,
 

- Hemant
Networking and Systems Integration Group
Satyam Computer Services Ltd

RE: /usr/ucb/cc: language optional software package not installed

(OP)
Hemant,

  Thanks for the reply. My questions is how do "I force my system to take GCC as default compiler"? Do I edit the Makefile.PL?

RE: /usr/ucb/cc: language optional software package not installed

ln -s `which gcc` /usr/ccs/bin/ucbcc

might work.

otherwise, yes you will have to edit the Makefile.

RE: /usr/ucb/cc: language optional software package not installed

When you run the configure script it looks for either cc or gcc.  What I would do is remove the full path for cc and replace it with the full path to gcc.  Also, after you have done all of that you should be able to run a "make clean" in the directory where the Makefile is to clean out any attempts you have tried previously.

May not work, but worth a shot.

J

RE: /usr/ucb/cc: language optional software package not installed

Solaris assumes that c programs are compiled with cc ... if the Makefile doesn't specify a CC it might just try to compile using the unspecified 'cc'

matters how well the Makefile/Makefile.in scripts were made together.

RE: /usr/ucb/cc: language optional software package not installed

Has anyone installed a Perl Module before? Is a C compiler always required. Im trying to Install MIME: LITE and during installation I noticed that the make program is not anywhere to be found on our Solairs 8 box. What are the steps that needs to be taken for our Administrator to install this module with the least frustration as possible?

Thanks!!!!!

RE: /usr/ucb/cc: language optional software package not installed

Did anybody have a final solution to this problem?

I am in the exact same boat and sinking fast!

Help..... :(

RE: /usr/ucb/cc: language optional software package not installed

My administrator had to install, I think I had permission issues more than anything.
I sent him this link if he had questions or issues.

http://www.perlmonks.org/index.pl?node_id=128077

RE: /usr/ucb/cc: language optional software package not installed

I have just found these precompiled binaries on this website, if it helps anybody else....

Now how to install them?

http://www.perltk.org/binaries/index.htm

RE: /usr/ucb/cc: language optional software package not installed

for this module I did not need a c compiler

RE: /usr/ucb/cc: language optional software package not installed

Make should be in /usr/ccs/bin
To get around the compiler problem you could rename cc (to wascc for instance ) and use the full path for gcc or even link /usr/local/bin/gcc to the origonal location of cc
(/usr/ucb/cc  maybe )

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close