Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

Kaos1 (Programmer) (OP)
14 Aug 00 10:15
Hello,

Does anyone have any advice on how to enable accounts? My root account has become disabled. Thanks
TheKidd (IS/IT--Management)
14 Aug 00 10:46
Log with another account that has access to SAM.  Go into SAM and reactivate the root account.
MikeLacey (MIS)
14 Aug 00 11:16
Try logging in from the console.

Mike
michael.j.lacey@ntlworld.com
Cargill's Corporate Web Site

Kaos1 (Programmer) (OP)
14 Aug 00 13:53
I do not have another account with access to sam. I am able to log on with another user at the console howerver, I am not able to su -. I also tried to boot into single-user mode and change my root password which was successful. On reboot, the root account was still disabled.
TheKidd (IS/IT--Management)
14 Aug 00 16:46
Sorry, I read your question wrong.  I thought that the root account was deactivated.
Kaos1 (Programmer) (OP)
14 Aug 00 17:36
I appriciate your response. Any other suggestions on what I might try?
MikeLacey (MIS)
14 Aug 00 18:09
Obvious question - sorry - but, can you run SAM from single user as root?

Mike
michael.j.lacey@ntlworld.com
Cargill's Corporate Web Site

ezetrade (IS/IT--Management)
15 Aug 00 5:00
A bit of a longshot but login as another user. Try the su command followed by password. Then try running sam. If this runs you should be able to reactivate root login.
Kaos1 (Programmer) (OP)
15 Aug 00 12:34
I tried but SAM will not run from single-user. I also tried to login as another user and the su command followed by the password. It still says the account is disabled. I can run SAM as a user but I do not have the privleges to add or remove users or groups.
MikeLacey (MIS)
15 Aug 00 12:45
Kaos -- are you running a "trusted system"?

Mike
michael.j.lacey@ntlworld.com
Cargill's Corporate Web Site

Kaos1 (Programmer) (OP)
15 Aug 00 15:41
I'm sorry, I am still new to the unix world. What do you mean by "trusted system"? If you mean do I allow others to use my system then no.
MikeLacey (MIS)
15 Aug 00 18:59
Hi Kaos,

A Trusted System is a way of running your HP box, it gives a higher degree of security than the standard way.

I asked because, when we converted to a trusted system, I began having trouble with the root login becoming disabled.

Unfortunately I'm not in the office tomorrow, and I don't have an HPUX computer at home. If you're still having trouble when I get back in the office (thu, sorry) I'll dig around and find out some stuff for you.

Mike
michael.j.lacey@ntlworld.com
Cargill's Corporate Web Site

Loon (Programmer)
16 Aug 00 5:56
Kaos1,

  after hunting through some man pages... I found this in man 1 login:

On a trusted system, login always allows user root to log in on the console unless /etc/securetty exists and does not contain console.

It also stated that the administrative lock could be set on that user account or the terminals involved..

So it is worth checking if a /etc/securetty exists and reading it to see if a console entry is in there. If it isn't then you may be a bit stuffed!

Another problem (which would be worse) is that on our systems at least /etc/securetty is read-only, requiring root privilages...

It might be worth searching the FAQs on hpsearch.com.

Good Luck!
Loon
Kaos1 (Programmer) (OP)
18 Aug 00 12:09
Mike and Loon,

The box was setup as a standard load. So I believe that it is not a trusted system. Also, I have an /etc/securetty file that needs root privileges to open or change. I search the HP faqs for anything on the root account becoming disabled and found nothing. I believe I'm stuck. Again, I appriciate any help you could give.
Thanks

Kaos1
TheKidd (IS/IT--Management)
18 Feb 02 12:46
Boot to single user mode.  Then mount /usr.  Then run the following command:

/usr/lbin/modprpw -kroot

This should work.  Let me know.
crowe (TechnicalUser)
19 Feb 02 10:10
You can tell very quickly if your HP is a "trusted" system by looking at the /etc/passwd file. If the /etc/passwd file contains encrypted passwords, the sytem is NOT trusted. If ALL the passwd fields are "*" this indicates that the system has been converted to a "trusted" system. The actual encrypted passwds are located in /tcb/files/auth/...

crowe
gerudman (IS/IT--Management)
20 Feb 02 7:03
Hi

Another thing you could try if you have a trusted system (use crowe's way to see if you have a trusted system or not by looking in /etc/passwd file), is to edit the /tcb/files/auth/r/root file.  You will see a line similar to this :

u_unsuctty=pts/tb:u_numunsuclog#1:u_lock:chkent:

Add a @ sign after the u_lock, so that the line looks like the following :

u_unsuctty=pts/tb:u_numunsuclog#1:u_lock@:chkent:

Hope this ends you nightmare!!

George

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Back To Forum

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close