Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

foxpro 6.0 app has error 1426 running on Windows XPHelpful Member! 

kimsue (Programmer)
14 Mar 02 16:32
I developed an application in Visual 6.0 (a while back-with some difficulty) that prints graphs.  I used the setup wizard to create the files I copy to the CD-ROM.  I included Microsoft Graph 8.0 Runtime when running the setup wizard.  Since that time, I have not worked in Visual Foxpro (reverted back to 2.6).  When I load the Visual 6.0 application on my new computer with Windows XP, I get the error described below.  The program works fine on my Windows 98 machine.  Any ideas?  I will be converting the Visual 6.0 application to Visual 7.0 (if I can ever get a handle on it).  Thank you in advance.  

The error occurs on this line:

APPEND GENERAL graph CLASS "msgraph.chart"

This is the error log:

Error # 1426.00
Program click
Message OLE error code 0x800401f3: Invalid class string. (800401F3: INVALID CLASS STRING)
Line #  40.00
Active: OH1SEL2 (cmdscreen)
Session 2.00
DiskSpc **********.**
Screen  600.00 by 800.00
OS      Windows 5.01
Vers(1) Visual FoxPro 06.00.8492.00 EXE Support Library for Windows [May  7 1999 17:48:36] Product ID
Vers(2) 0.00
Vers(3) 00
SMode   4.00
(1016)  1403.01 user object memory used
(1001)  1046656.00 pool available memory
CPU     Pentium
Video   Color/Color
Helpful Member!  rgbean (Programmer)
14 Mar 02 17:50
You may need to upgrade your VFP 6.0 - you appear to be running SP 3, and the last one was SP 5.

Rick
kimsue (Programmer)
14 Mar 02 18:24
Error # 1426.00
Program click
Message OLE error code 0x800401f3: Invalid class string. (800401F3: INVALID CLASS STRING)
Line #  466.00
Active: OH1SEL2 (cmdscreen)
Thank you.  I will download that later tonight.  In the meantime, I get back to the ORIGINAL question (which I didn't ask).  What changes do I need to make in Foxpro 7.0 to accomplish this same graph?  That was my original problem.  I installed the 6.0 version to see if that worked (didn't).  I was only trying to recompile the 6.0 project in 7.0.  I'm just getting into it.  Thank you once again.  The error log from 7.0 is:     
  

Session 2.00
DiskSpc **********.**
Screen  600.00 by 800.00
OS      Windows 5.01
Vers(1) Visual FoxPro 07.00.0000.9465 EXE Support Library for Windows [Jan  4 2002 03:07:19] Product ID
Vers(2) 0.00
Vers(3) 00
SMode   4.00
(1016)  1892.88 user object memory used
(1001)  1046656.00 pool available memory
CPU     Pentium
Video   Color/Color
kimsue (Programmer)
15 Mar 02 7:20
More information...  

The graph was created by the graph wizard.  When I try to use the Graph Wizard in Visual 7.0, I get a message saying "Microsoft Graph appears to be installed incorrectly-The latest version of Graph is available from Microsoft Office".  I do not have Microsoft Office installed on the XP machine.  I did install Visual Foxpro 6.0 and Foxpro 2.6 (problem??).  Is Microsoft Graph available in Foxpro 7.0?  I have graph8.exe and graph.exe (assuming from 2.6).  What program is the Visual 7.0 graphing wizard looking for and where can I find it???  Thank you in advance.
  
rgbean (Programmer)
15 Mar 02 9:25
OK, no solutions, but did you load up the Samples code from the MSDN CD? If you did, try:
DO (_samples+"\solution\solution")
Then go to ActiveX -> Automation -> Manipulate display characteristics of a graph.
This uses MSGRAPH.CHART, see if this runs. It does on my XP Pro system, under both VFP 6.0 SP5 and VFP 7.0 SP1. The registry shows I have both .5 and .8 installed, with .8 being current. However, I do have Office XP (v10) installed and the registry shows that the "server" for MSGRAPH.CHART.8 is C:\PROGRAM FILES\MICROSOFT\Office10\GRAPH.EXE.

So it may be that the MSGRAPH "runtime" is not compatible with XP.

I also found http://support.microsoft.com/default.aspx?scid=kb%3Ben-us%3BQ112483 - "INFO: Limitations of Run-Time MS Graph (Q112483)".

Rick
kimsue (Programmer)
18 Mar 02 14:23
The sample automation DOES NOT run on my machine.  I will post an answer if I find one.  Thanks.
kimsue (Programmer)
19 Mar 02 19:59
I installed Office 97 (don't have the newest version) and the graphs now work (as do the samples in sample.app).  I still need to make sure the graphs will work on a customer's machine if they do not have Office installed.  The Visual Foxpro version of MS Graph runtime installed by the SETUP Wizard does not appear to work on XP.???  If anyone has an answer here, I'd appreciate it; otherwise, I'll post an answer if/when I have one.  Thanks.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close