Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

Data source name not found and no default drivers specified!

mthakershi (Programmer) (OP)
4 Mar 02 17:12
Hi all,

I have never connected to Paradox in my life. I need to use it with ADO in a project. I came to know that it needs BDE 5.1 and ADO 2.6 library. I have those. I am using following statement to connect to the database. I have already installed Paradox 9.0 on my system.

pCon.Open "Driver={Microsoft Paradox Driver(*.db)};DriverID=538;Fil=Paradox 5.X;DefaultDir=c:\TestGenExport\;Dbq=c:\TestGenExport\;CollatingSequence=ASCII;"

It gives me runtime error, saying "[Microsoft] [ODBC Driver Manager] Data source name not found and no default drivers specified."

Please reply to this.

Appreciate it,
Malay Thakershi
ibearian (TechnicalUser)
15 Mar 02 9:51
what version of paradox are you using?
mthakershi (Programmer) (OP)
15 Mar 02 13:16
I am using 9.0 version of Paradox.
Malay
ibearian (TechnicalUser)
15 Mar 02 15:31
the ms driver odbc driver does not work above verion 5 or 6 (i can't remember) you need the intersolv driver that ships with paradox. how and what are you connecting to your paradox db? and how are you using ado via odbc or native via bde ?
footpad (Programmer)
15 Mar 02 15:52
Malay,

Iberian's right; you'll want to install the Intersolv driver provided on your Paradox 9 CD.  Once you have that, use the ODBC Data Sources Administrator to define your connection the Paradox tables.

Hope this helps...

-- Lance
mthakershi (Programmer) (OP)
17 Mar 02 16:09
Hey Guys,
Thanks for replying. I created system data source using INTERSOLV 3.11 32-BIT PARADOXFILE (*.DB) driver, which was installed on my system with Paradox. When I opened connection by following statement, it worked.
pCon.Open "DSN", "USERID", "PASSWORD"

But I don't want to use DSN when I connect via ADO. In this case, the connection string I am using is as follows:

pCon.Open "Driver={INTERSOLV 3.11 32-BIT ParadoxFile (*.db)};DriverID=538;Fil=Paradox 5.X;" & _
                 "DefaultDir=c:\TestPara\;Dbq=c:\TestPara\;CollatingSequence=ASCII;"

My all DB files are in "C:\TestPara\" directory. Now when I query one of the table 'Patient' by executing "Select Count(*) from Patient", it gives error saying this table does not exist.

Please suggest me a way to connect without creating DSN. The above connection string I found on one website and I suspect DriverID parameter, I am not sure.

Any help is appreciated.

Thanks again,
Malay
ibearian (TechnicalUser)
18 Mar 02 3:06
So are you connecting paradox >>bde>>ODBC>>ADO>> application ?

(if so you are using the ado driver to interogate ODBC, Yes?)

What your application (packaged software or self built)?

I know little about ADO connection strings only that you generally configure them through the queiring application, (as you already know). I use Crystal Reports and ADO works great with its 'wizzard' making the connection strings. So i am lazy, but it easy.... should the 'Fil' command not be Paradox 9.x ??? Between paradox 5 and 7 they went to the BDE and created a whole new set of problems. So Paradox 5 is as different to paradox 9 as Access to FoxPro (well kind of, you probably already know).

The 'table does not exist' error generaly refers to the network directory not being set properly. Have you set this in the ODBC driver ?

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Back To Forum

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close