INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

IVR not working in IPOCC

IVR not working in IPOCC

(OP)
Hi All,
I made a task flow with an IVR script, the call disconnects once it reaches the IVR without even playing the IVR announcement.
when I remove the IVR from the task flow & connect the caller directly to an agent group, it works fine.
I reviewed the IVR script several times & verified it without any errors, I even used the exact same IVR example in the TBG with no success.
anyone had this issue before?

Here is the Logs

C6281e TT_Version *******************************************************************************
TT_Version * *
TT_Version * Voice Control *
TT_Version * *
TT_Version * Version : 100.3.33130.8600 *
TT_Version * Build : Feb 1 2017 - 02:32:36 *
TT_Version * Started : Mon Dec 18 13:20:40 2017 *
TT_Version * Machine : ipocc, 192.168.100.12 *
TT_Version * Proc ID : 8784 *
TT_Version * *
TT_Version * Copyright (c) 2003-2017 *
TT_Version * *
TT_Version *******************************************************************************
H2836e 13:25:18.078 VC_VUS [0x00002284] --- ActiveScript: masterMenuScript, invokeId=0x1EAC47, Port=0, plci=0xD20C0034
H2837e 13:25:18.079 VC_VUS [0x00002284] VUS_Element:ElemStart(start,masterMenuScript,0xD20C0034,0,0x1EAC47)::run(0x3FB4E58) Starting Element
H2838e 13:25:18.079 VC_VUS [0x00002284] VUS_Element:ElemStart(start,masterMenuScript,0xD20C0034,0,0x1EAC47)::run(0x5F4D1F5711010800) SUCCESS Element Finished
H2839e 13:25:18.079 VC_VUS [0x00002284] VUS_Element::ElemSetVar(DefineRetryVal,masterMenuScript,0xD20C0034,0,0x1EAC47)::run(0x5F4D1F5711010800) Starting Element
H2849e 13:25:18.088 VC_VUS [0x00002284] VUS_Element::ElemSetVar(DefineRetryVal,masterMenuScript,0xD20C0034,0,0x1EAC47)::run(0x5F4D1F5711010600)SUCCESS RetryVal=0
H2850e 13:25:18.088 VC_VUS [0x00002284] VUS_Element::ElemDtmf(MenuSelection,masterMenuScript,0xD20C0034,0,0x1EAC47)::run(,0x5F4D1F5711010600) Starting Element m_wait->m_abort was 0
H2851e 13:25:18.095 VC_VUS [0x00002284] --- VUS_PlayFile::startPlay FileName: MasterMenuOne.wav
H2853e 13:25:20.232 VC_VUS [0x00004BA4] VUS_Script(masterMenuScript)::disconnecting() ...
H2854e 13:25:20.232 VC_VUS [0x00004BA4] VUS_Script(masterMenuScript)::disconnecting() ...
H2855e 13:25:20.232 VC_VUS [0x00004BA4] VUS_Script(masterMenuScript)::disconnecting() - call at element class VUS_ElemDtmf(MenuSelection,masterMenuScript,0xD20C0034,0,0x1EAC47)
H2856e 13:25:20.232 VC_VUS [0x00004BA4] VUS_Element::ElemDtmf(MenuSelection,masterMenuScript,0xD20C0034,0,0x1EAC47)::abort() delay=150 begin
H2857e 13:25:20.383 VC_VUS [0x00004BA4] VUS_Element::ElemDtmf(MenuSelection,masterMenuScript,0xD20C0034,0,0x1EAC47)::abort() delay=150 end
H2858e 13:25:20.383 VC_VUS [0x00004BA4] VUS_PlayFile::abortPlay
H2859e 13:25:20.558 VC_VUS [0x00002284] VUS_Element::ElemDtmf(MenuSelection,masterMenuScript,0xD20C0034,0,0x1EAC47)::run() VUS_Wait (0x0113B4B8) aborted: 0 sleep(5sec.)
H2860e 13:25:20.585 VC_VUS [0x00004BA4] VUS_Element::ElemDtmf(MenuSelection,masterMenuScript,0xD20C0034,0,0x1EAC47)::abort() VUS_Wait (0x0113B4B8) aborted: 0::wakeup()
H2861e 13:25:20.636 VC_VUS [0x00002284] VUS_Element::ElemDtmf(MenuSelection,masterMenuScript,0xD20C0034,0,0x1EAC47)::run() VUS_Wait (0x0113B4B8) aborted: 0 sleep(5sec.) expired/aborted.
H2862e 13:25:20.636 VC_VUS [0x00002284] VUS_Element::ElemDtmf(MenuSelection,masterMenuScript,0xD20C0034,0,0x1EAC47)::run(,0x5F4D1F5711011200) ERROR error=9103 disconnecting (8)
H2863e 13:25:20.636 VC_VUS [0x00002284] VUS_Element::ElemIf(ChkRetryVal,masterMenuScript,0xD20C0034,0,0x1EAC47)::run(0x5F4D1F5711011200) Starting Element
H2864e 13:25:20.636 VC_VUS [0x00002284] VUS_Element::ElemIf(ChkRetryVal,masterMenuScript,0xD20C0034,0,0x1EAC47)::run(0x5F4D1F5711010900,NO) Finished Element
H2865e 13:25:20.636 VC_VUS [0x00002284] VUS_Element::ElemSetVar(IncrementRetryVal,masterMenuScript,0xD20C0034,0,0x1EAC47)::run(0x5F4D1F5711010900) Starting Element
H2866e 13:25:20.636 VC_VUS [0x00002284] VUS_Element::ElemSetVar(IncrementRetryVal,masterMenuScript,0xD20C0034,0,0x1EAC47)::run(0x5F4D1F5711010A00)SUCCESS RetryVal=1
H2867e 13:25:20.636 VC_VUS [0x00002284] VUS_Element::ElemText(invalopt,masterMenuScript,0xD20C0034,0,0x1EAC47)::run(0x5F4D1F5711010A00) Starting Element
H2868e 13:25:20.637 VC_VUS [0x00002284] VUS_Element::ElemText(invalopt,masterMenuScript,0xD20C0034,0,0x1EAC47)::run(0x5F4D1F5711011000) disconnecting
H2869e 13:25:20.637 VC_VUS [0x00002284] VUS_Element:ElemStop(End,masterMenuScript,0xD20C0034,0,0x1EAC47)::run(0x5F4D1F5711011000) Starting Element
H2870e 13:25:20.637 VC_VUS [0x00002284] VUS_Element:ElemStop(End,masterMenuScript,0xD20C0034,0,0x1EAC47)::run(0xFFFFFFFFFFFFFFFF)SUCCESS Element Finished
H2871e 13:25:20.637 VC_VUS [0x00002284] --- RemoveActiveScript: masterMenuScript, invokeId=0x1EAC47, Port=0, PLCI=0xD20C0034
H2872e 13:25:20.637 VC_VUS [0x00002284] VUS_Script(masterMenuScript)::~VUS_Script deleting port=0


thanks in advance

RE: IVR not working in IPOCC

Did you verify that PBXServer was selected in the IVR properties?

RE: IVR not working in IPOCC

(OP)
Yes... this is not about IVR But in the task flow editor when basically connect the topic to simply wait announcement and when dial the topic nimber hear busy tone then the call disconnect .

RE: IVR not working in IPOCC

Can you share a screen shot of your task flows?

RE: IVR not working in IPOCC

Have you got media security settings set to preferred in IP Office?

Are the IVR announcements in the correct folder?

ACSS - SME
APSS - SME
APDS - Unified Communications
ACS - IP Telephony
ACA - IP Telephony

RE: IVR not working in IPOCC

(OP)
When set the media security to prefered all the ip phones disconnect... When asked about it. told me that because the phones is 1600 series not important to set the voip security to prefered.
Yes the voice announcement is in the correct files.

Thanks

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close