Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.


Micros e7 - "Software License Key cannot be found"

Micros e7 - "Software License Key cannot be found"

Hi All,

Looking for some help here. Our Micros e7 started giving us a prompt that says "Software license key cannot be found", but it is plugged into the same USB port it always has been. I've tried different USB ports and re-starting the server computer but no dice.

Thanks in advance!

RE: Micros e7 - "Software License Key cannot be found"

Well...the key could be bad. Have you had a power-outage, or lightning-strike; hard shut-down...something like that?

Other than that...there are some files that will cause it to not be recognized; but I'm sorry...I forget the extension right now ponder

RE: Micros e7 - "Software License Key cannot be found"

If you have more than one terminal or a license on the server swap the keys. If issue follows the key then it's bad. When you switched the USB port did you reboot the tterminal?

RE: Micros e7 - "Software License Key cannot be found"

Thanks for the responses. I think the key is no longer working. Am I able to just purchase a key off ebay or something and it will work?

RE: Micros e7 - "Software License Key cannot be found"

I haven't dealt with e7 in a while, but I know Oracle required the removal of the key requirement. There's either a version or a utility that can fix your issue on the Oracle Website.

RE: Micros e7 - "Software License Key cannot be found"

Key-less, is only applicable...up above, a certain version; and I don't think it would give a "key not found error".

RE: Micros e7 - "Software License Key cannot be found"

I worked for Micros for 10 years. e7 keys would go bad on a reasonably regular basis. I'm sure that's what happened here. The question is what to do about it. A quick glance on Google shows that the version that supports keyless is e7 4.0 mr1 or above. Oracle makes the patches available somewhere on their website. If Samrmacist is using 4.0 mr1 or above (or 3.3 mr7) he apply the keyless patch. If he's below 4.0 mr1 he can patch up to 4.0 mr1 (or 3.3 mr7) and then apply the patch. If he's using Workstation 4's (green vertical rectangle powerlight in the lower right hand corner of the touchscreen) he should not patch. If he can find a key on ebay for a reasonable price he could also do that.

RE: Micros e7 - "Software License Key cannot be found"

I'm having the hardest time finding these patches on the Oracle website and the help lines for both Micros + Oracle get me nowhere as I don't have a valid service contract (worst customer service ever).

I found and ordered a network key on Ebay but waiting for it's arrival and my e7's grace period has ended. Unable to login and ring in any sales.

Is this the patch?

RE: Micros e7 - "Software License Key cannot be found"

No. I knew where it was on the old Micros website, but that's been discontinued. Downloading Oracle patches is an unholy mess... Do you have a server? If you take the key from it and put in the workstation. There's nothing critical you have to do on the server during business hours.

RE: Micros e7 - "Software License Key cannot be found"

We do have a server, I will try that but I believe the key is dead. Is there a way to get the contents of the key and put it on another usb key?

RE: Micros e7 - "Software License Key cannot be found"

It's not possible. If memory serves me not having a key on the server does almost no harm, and you will have a 7 day grace period while your ebay key arrives where nothing is prevented, so I'd just move it over to the touchscreen.

RE: Micros e7 - "Software License Key cannot be found"

Max, that worked! Thank you sooooooo much for your help! How can I ever re-pay you?

RE: Micros e7 - "Software License Key cannot be found"

No problem, I'm happy to help.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close