INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Avaya IPOCC Webchatapp not connecting to topic1

Avaya IPOCC Webchatapp not connecting to topic1

(OP)
Hello,

please i am having issues connecting Avaya IPOCC WebchatApp to a chat session. It gives the following error on the Logs:

"K7818a 12:58:46.110 WCPROXY_Core_Warning Session (54b6ae69-c8e3-44c3-a455-112a03ad732a) works on DEAD END--> some client works with an illegal session
K7817a 12:58:46.110 WCPROXY_Core_Warning WebChatSOAP.createSession():> session creation failed for user
M6155a 13:29:59.584 WCPROXY_Core_Error Anonymous login failed.:

M6154a 13:29:59.584 WCPROXY_Core_Error WebChatSessionFactory.createSesson():> connection to cdlavayaipocc.fcmb.com:5,222 failed
M6152a 13:29:59.582 WCPROXY_Core_Error XMPPClient():> server login failure --> please check credentials or anonymous option of server"

I am using Open Fire as XMPP. It seems the issue is with the XMPP credentials, which i have corrected so many times:
XMPP Host Name:
Port:5222
XMPP Domain: same as open fire

I am not sure of how to troubleshoot further.Any ideas?

RE: Avaya IPOCC Webchatapp not connecting to topic1

Hi

Still in training for the IPOCC but looking at your logs this string looks a bit faulty, dont think it should be a comma in the port number?

M6154a 13:29:59.584 WCPROXY_Core_Error WebChatSessionFactory.createSesson():> connection to cdlavayaipocc.fcmb.com:5,222 failed

RE: Avaya IPOCC Webchatapp not connecting to topic1

(OP)
yeah, you are right.i don't think there should be comma in the port number, but that is what is showing in the logs?

please can anyone show me a WebchatApp.properties file that works already for Avaya Java Webchat Examples?

Thanks

RE: Avaya IPOCC Webchatapp not connecting to topic1

(OP)
It is working now,it wasn't able to create a user session on the XMPP Server.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close