INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Win 10 + FireFox + XMarks (former Foxmarks)

Win 10 + FireFox + XMarks (former Foxmarks)

(OP)
I just got an ordinary Dell laptop running Win 10 Home. Nothing fancy!
I have a bunch of other computers at home and I've been using XMarks for the past... 15-20 years... on Macs and Windows computers.

Simply a long time!

It seems as though I'm the only person in the world with this combo, Win 10 + Firefox + XMarks, because I couldn't find any other reported issue!
Simply, it will not work!

No sync is made... Settings is all wacko and all seems so different from the previous ten - or so - installs that I've made during the years!

There is a neat link about FireFox saying that in November of 2017 there will be a whole new release an third party developers must update...

Of-course, I can't find that link at the moment, sitting at another computer(!!)...
https://www.google.com/search?q=firefox+november+2...

Are there any known issues about this...!? Or is it simply me!! smile

RE: Win 10 + FireFox + XMarks (former Foxmarks)

Not just you, a lot of people are having issues according to the xmarks add on link. Sounds like until Last pass makes an update, it won't function.

RE: Win 10 + FireFox + XMarks (former Foxmarks)

(OP)
Thank you!!
This post means very much for me, because I didn't find any information of this in Internet.
But... at the other hand.
Maybe I need to be patient and I shall wait until November.... to see, what happens with FireFox 57! Maybe XMarks will work with that edition!?

I rest my case!

RE: Win 10 + FireFox + XMarks (former Foxmarks)

(OP)
I'm not so sure about LastPass. I've heard of it... But never used or made any notice.

https://support.mozilla.org/sv/kb/firefox-tillaggs...

This page is in Swedish, from a link inside Fire Fox, along with the addon Xmarks.
I couldn't find it in English, I was looking.
According to this page, all will be good by November where old things will stop working and all addons will need to use the new framework.... Xmarks will use that framework.

Does this means that all there is at the moment are failing copies of Xmarks and no sync is being made from any place to any one...?
If so, I was expected to find more when doing a google search! It's all!

November will be in 20-30 days... so, just to wait and then download!! What could possibly go wrong!? winky smile

RE: Win 10 + FireFox + XMarks (former Foxmarks)

LastPass is the company that now own and develop XMarks.

RE: Win 10 + FireFox + XMarks (former Foxmarks)

2
The lastpass add in in Firefox will stop working when Firefox gets to version 57 (it is currently 56). Since I am a paid user and eligible for support, I asked lastpass when the new API will be implemented. I got the following response

Thanks for emailing us. FireFox 57 only supports extensions that are fully on the WebExtensions API.
LastPass is not WebExtensions API compatible and, therefore, will not work in Firefox 57 versions.
Firefox plans to release 57 to the stable build in November and we will be ready by then. You can see the planned scheduling for Firefox 57 here:
https://en.wikipedia.org/wiki/Firefox_version_hist...
But we are working towards this and will be compatible before it releases to the stable version.


Bill
Lead Application Developer
New York State, USA

RE: Win 10 + FireFox + XMarks (former Foxmarks)

(OP)
Thank you!
That's mostly the same information as I posted above... but I couldn't find it in English.
Excuse me.

Now... a new "feature" appears! When importing my bookmarks from html, they don't show in the menu... the menu is visible... but they show while typing in the address field!

Oh, well! Maybe it will go away later!
Life is full of surprises!! smile

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close