INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Access 2016: Hyperlinks Broken when Printing to PDF

Access 2016: Hyperlinks Broken when Printing to PDF

(OP)
So at least I figured out a solution here, but it's not an acceptable solution...

I have a database to store song names and track information and performance history. When I pick the order for the next gig, I have links in my Access report, which were properly stored in the tblSongs, that would take the band members to Youtube so they can listen to the songs to prepare. Up until last week the links, for whatever reason, were working. Now they are not.

It seems that unless the link is stored as http://www.youtube.com/etc/etc/etc it won't work when printed to PDF. And some of those links are pretty long so they may not fit in the report.

I had each link stored as the SongName#http://www.youtube.com/etc/etc/whatever, so they appeared in the report and such as the song name rather than something illegible.

One, why did it break? Two, why isn't it working now? When I open the report in "Report View", the links work just fine. When I "Print Preview" and then "Print", the links in the resulting PDF do not work. But they used to. That's the really weird thing.

This happens whether I use Nitro, or Adobe, to print to PDF.

Your help is much appreciated.

Thanks!!


Matt

RE: Access 2016: Hyperlinks Broken when Printing to PDF

(OP)
So this is the strangest thing. I figured it out.

When I use a macro to print the report to PDF automatically, the links will work.

If I open the report from the 'Reports' section, then print it manually to PDF, no matter if I open it in 'Report View' or 'Print Preview' or w/e, the links will NOT work. Strangest thing...

The macro is set as follows:

ExportWithFormatting
Object Type: Report
Object Name: Service - Order (that's the report name, of course)
Output Format: PDF Format (*.pdf)
Output File: (blank)
Auto Start: No
Template File (blank)
Encoding: (blank)
Output Quality: Print

Hope this helps someone else.

Thanks!!


Matt

RE: Access 2016: Hyperlinks Broken when Printing to PDF

Office documents exported to pdf preserve links, exporting to pdf is different from printing. Check your pdf printer settings.

combo

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close