INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

IPOCC UI Over VPN problem

IPOCC UI Over VPN problem

(OP)
Hi all,

IPO 10.0.
IPOCC 10.1

We have 2 locations connected through VPN over MPLS . A - main loc where IPO and IPOCC installed. B - secondary loc - only 1 Agent configured yet.

the phone is Avaya 1616 - and it connects to IPO and there is no problem with voice or signaling.
When the agent logs on UI and handles a call (it maybe the 1st call, second call or 3rd.. random.. ) - outbound or inbound, then the UI freezes and then gets errors on top right " The connection to the telephone system is interrupted" and "No connection to taskreporting database!" . When the agent tries to connect again she gets "No connection to WebLM server" but after 5 min if she tries again it works until the next call/calls when she gets disconnected again.

I have turned off firewall on agent pc and also upgraded IPOCC from 10.0. to 10.1 - no use.

Now.. we have only 1 supervision licence and I have configured 4 agents to be able to add customers - Cofnugration -> Customers but I didn't get any licence errors when signing in so I don't know if it has something to do with it..
In the CCUI TTrace for that agent PC I see :

D6009b 15:34:30.882 UI_FWGeneral The agent doesn't have the sufficient privileges to start application adrbookcfg. Application will not be available!
D6010b 15:34:30.882 UI_FWGeneral The agent doesn't have the sufficient privileges to start application chat. Application will not be available!
D6011b 15:34:30.882 UI_FWGeneral The agent doesn't have the sufficient privileges to start application dialer. Application will not be available!
D6012b 15:34:30.882 UI_FWGeneral The agent doesn't have the sufficient privileges to start application email. Application will not be available!
D6013b 15:34:30.882 UI_FWGeneral The agent doesn't have the sufficient privileges to start application ivreditor. Application will not be available!
D6014b 15:34:30.882 UI_FWGeneral The agent doesn't have the sufficient privileges to start application monitoring. Application will not be available!
D6015b 15:34:30.882 UI_FWGeneral The agent doesn't have the sufficient privileges to start application statistic. Application will not be available!
D6016b 15:34:30.882 UI_FWGeneral The agent doesn't have the sufficient privileges to start application tfeditor. Application will not be available!
D6017b 15:34:30.882 UI_FWGeneral The agent doesn't have the sufficient privileges to start application tragent. Application will not be available!
D6019b 15:34:30.882 UI_FWGeneral The agent doesn't have the sufficient privileges to start application trcontact. Application will not be available!
D6020b 15:34:30.882 UI_FWGeneral The agent doesn't have the sufficient privileges to start application uiconfiguration. Application will not be available!
D6021b 15:34:30.882 UI_FWGeneral The agent doesn't have the sufficient privileges to start application umrcfg. Application will not be available!
D6022b 15:34:30.882 UI_FWGeneral The agent doesn't have the sufficient privileges to start application umrtextcfg. Application will not be available!
D6023b 15:34:30.882 UI_FWGeneral The agent doesn't have the sufficient privileges to start application wallboard. Application will not be available!
D6026b 15:34:30.976 UI_HomeGeneral Home control starting up. HFSControl::initialize()

Can it be a licence problem?


So the VPN connection works well on all other apps the client uses, even the AVaya IP Phone..
Now this looks like a VPN connection problem for me but what do you guys think? what should I check to make sure UI and IPOCC are working as designed and there is something between them causing this? What would be your approach? Is there other info you would need from me? bigsmile

Thank you !
Vlad C.

RE: IPOCC UI Over VPN problem

I kinda hung up on VPN over MPLS =)

Is it VPN or MPLS ?

"Trying is the first step to failure..." - Homer

RE: IPOCC UI Over VPN problem

(OP)
upsidedown
So this is a VPN connection. but from what I know VPN can run over a public internet or over a dedicatet MPLS (i mean the routes can be controled by the provider..) I am not a network specialist so I hope what I say makes sense

RE: IPOCC UI Over VPN problem

Usually a MPLS network is a "service provider controlled VPN" so there's no need to add VPN on top of that.
But it does sound a bit like the VPN connections drops.

The errors you see if just when it check what configuration options the agent should have avaliable in the client.

"Trying is the first step to failure..." - Homer

RE: IPOCC UI Over VPN problem

(OP)
Ok so VPN over MPLS is a pleonasm :))

They have mpls.. period :))

Now, I have attached a wireshark trace captured on IPOCC Server.
If you guys have time to look over it.

IP: 10.0.6.3 - ip addr of UI location C
IP: 10.0.2.9 - ip IPOCC
IP: 10.0.3.94 - ip of UI from primary location where there is no problem.

change the view of trace for date and time. The prbolem started at 10:36
If you filter by ip.addr==10.0.6.3 you will see there are malformed packets.. why, I don't know.. if I comper the filter results of ip.addr==10.0.3.94 you will not see such packets.

Also for the filter ip.addr==10.0.6.3 I see TCP Spurious Retransmission . I think this indicates that packets are being lost. what do you think ?

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close