INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Can't browse (route?) from anything connected to DHCP pool

Can't browse (route?) from anything connected to DHCP pool

(OP)
This is driving me dingy.
I have the below configuration (sanitized) on a Juniper EX-4200 switch.

The switch is connected to a router whose address is XXX.XXX.176.189
The switch is set to XXX.XXX.176.190

If I configure a laptop to the XXX.XXX.176.190 and plug into the router I can browse the Internet. So I know the router is working.
If I plug the switch into the router I can Ping google, whatever, so I know THAT is working.

I have a DHCP pool set up XXX.XXX.168.1 on the switch. From the switch I can ping XXX.XXX.168.1

I have port 12 on the switch configured as an access port on the DHCP VLAN. If I plug a computer into that port, I get a DHCP address and I can ping XXX.XXX.168.1 from the computer.

I CAN'T ping XXX.XXX.176.189 or XXX.XXX.176.190 or anything on the Internet from the computer - it's like the DHCP pool is isolated from everything and not passing traffic.

Any ideas? Thanks

version 11.4R1.6;
system {
host-name Uplink_SW1;
time-zone America/New_York;
root-authentication {
encrypted-password "XXX"; ## SECRET-DATA
}
name-server {
8.8.8.8;
}
login {
user XXX {
uid 2000;
class super-user;
authentication {
encrypted-password "XXX"; ## SECRET-DATA
}
}
user XXX {
uid 2001;
class super-user;
authentication {
encrypted-password "XXX"; ## SECRET-DATA
}
}
}
services {
ssh;
telnet;
web-management {
http;
}
dhcp {
pool XXX.XXX.168.0/24 {
address-range low XXX.XXX.168.226 high XXX.XXX.168.254;
name-server {
8.8.8.8;
8.8.4.4;
}
router {
XXX.XXX.168.1;
}
}
}
}
max-configurations-on-flash 49;
ntp {
server 129.6.15.30;
}
}
chassis {
fpc 0 {
pic 1 {
sfpplus {
pic-mode 10g;
}
}
}
alarm {
management-ethernet {
link-down ignore;
}
}
}
interfaces {
ge-0/0/0 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/1 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/2 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/3 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/4 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/5 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/6 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/7 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/8 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/9 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/10 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/11 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/12 {
description "Local port";
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members Subscriber_Data;
}
}
}
}
ge-0/0/13 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/14 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/15 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/16 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/17 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/18 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/19 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/20 {
description "Local port";
unit 0 {
family ethernet-switching {
vlan {
members Local;
}
}
}
}
ge-0/0/21 {
description Uplink_To_XXX;
unit 0 {
family inet {
address XXX.XXX.176.190/30;
}
}
}
ge-0/0/22 {
description "MXK management";
unit 0 {
family ethernet-switching {
vlan {
members 100;
}
}
}
}
ge-0/0/23 {
description Uplink_To_Local;
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members all;
}
}
}
}
xe-0/1/2 {
unit 0 {
description Trunk_Port_to_OLT;
family ethernet-switching {
port-mode trunk;
vlan {
members all;
}
}
}
}
vlan {
unit 100 {
description "Management VLAN";
family inet {
address 10.0.0.1/24;
}
}
unit 200 {
family inet;
}
unit 500 {
family inet {
address XXX.XXX.168.1/24;
}
}
}
}
routing-options {
static {
route 0.0.0.0/0 next-hop XXX.XXX.176.189;
}
}
vlans {
Local {
vlan-id 200;
l3-interface vlan.200;
}
Subscriber_Data {
vlan-id 500;
l3-interface vlan.500;
}
management {
vlan-id 100;
l3-interface vlan.100;
}
}

{master:0}

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close