INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Incomming number from SIP trunk shows +49xxxx

Incomming number from SIP trunk shows +49xxxx

(OP)
Hi all,
we are just moving from ISDN to SIP trunking for our entire Environment. Now we startet testing and when we recive an incomming call from the sip trunk it is in E164 Format with the international prefix (+49 for calls out of Germany). Now in the call log of the phones I have this number and I am not able to do a call back. Any idea how I can get ride of that international prefix?

regards
Stephan

RE: Incomming number from SIP trunk shows +49xxxx

Assuming your SIP trunk is coming in via Session Manager you can use the adaptation module to strip 1 digit if the number starts with plus (+)

RE: Incomming number from SIP trunk shows +49xxxx

(OP)
Correct, I am working with an SM but until now I had no success to strp of that +. So would you do this in the adaptation for the SBC or for the ACM? thanks. The Problem is not that I can not reach an extension on the ACM but the Information in the Display of the station.

RE: Incomming number from SIP trunk shows +49xxxx

have tried changing this configs from the signaling?

Prepend '+' to Outgoing Calling/Alerting/Diverting/Connected Public Numbers? n
Remove '+' from Incoming Called/Calling/Alerting/Diverting/Connected Numbers? n

RE: Incomming number from SIP trunk shows +49xxxx

(OP)
ok I was now able to remove the + in the Adaptation from the SM. Thanks to that https://andrewjprokop.wordpress.com/2015/09/09/an-...

Now I have an additional issue. I am using EC500! When I only covert the + to 00 in the Adaptation I get the right number on my mobile but I am still missing one 0 in the Display off the phone for calling out of the phone call log. When I add 000 in the Adaptation I get the correct number in the phone call log but not the correct one on my mobile sad. So somehow I am looking for a possibility to add the ars code automatically to the call log of my phones.

RE: Incomming number from SIP trunk shows +49xxxx

You probably need to use the call type analysis tables rather than prefixing ARS codes into the call log.

Much easier and flexible

Take Care

Matt
I have always wished that my computer would be as easy to use as my telephone.
My wish has come true. I no longer know how to use my telephone.

RE: Incomming number from SIP trunk shows +49xxxx

(OP)
ok guys, thanks a lot that worked. I have never worked with call type Analysis so it was first a little bit tricky. I had to reboot the ip phone to get it to work (have read this in another threat). So issue is solved.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close