INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Jobs from Indeed

Contact Header

Contact Header

(OP)
Hello everyone,

For some reason I can get version 8.0 (46) to show the correct Contact header information, as shown below:

Contact: <sip:72777XXXXX@192.168.21.60:5060;transport=udp>;expires=60

It is showing the internal IP and I have tried the following:

Use Network Topology Info (both) LAN1 and NONE

Under Network Topology I have 0.0.0.0 as STUN server "Full Clone NAT" (Also tried Open Internet) and the public IP Address as my public (STATIC) IP.

I even tried putting the External IP in the ITSP Proxy Address.

Have any suggestions?

Thanks everyone!!

Mike



RE: Contact Header

(OP)
Just an update:

Adding a STUN server (Tried a few different ones) corrects the Contact Header format and changes the Firewall/NAT Type to "Port Restricted Cone NAT" and sets the Public Port to 49153. When the STUN server set the Public Port to 49153 I get no audio. I set the Public Port back to 5060 and
remove the STUN server IP and then everything is great except the Contact Header format reverts back to my internal LAN IP and long distance calls are hit or miss.


Also I am using LAN1, my ARS rule is N"@sip.privder's.domain

Contact: <sip:72777XXXXX@192.168.21.60:5060;transport=udp>;expires=60 <-- Do not want
Contact: <sip:72777XXXXX@XXX.XXX.18.150:5060;transport=udp>;expires=60 <-- Want

Any thoughts?

Mike

RE: Contact Header

(OP)
I am still fighting this problem, any help would be greatly appreciated!!

I sent a trace to Flowroute and this was their response.

Thanks for the capture. The capture shows that your system is showing your private IP address 192.168.21.60 in your signaling SIP Contact header, which causes no audio or one-way audio intermittently, especially when calling toll-free number.
Please modify your system to show your public IP XXX.XXX.18.150 as the SIP contact header.
Below is a general guide that explains how to do this on common Asterisk-based systems.
https://support.flowroute.com/customer/portal/arti...


Flowroute Support


Thanks again,

Mike

RE: Contact Header

Try this

In network topology
Set firewall type to Static port block
Remove the stun server and uncheck run stun on startup
Enter public IP address into public IP field
change ports to 5060

SIP Line
Transport
Change Use Network Topology info to LAN1 (or LAN2 if that is the connection to your SIP)

This should present your public IP to your SIP provider. If that does not work try firewall type as Port Restricted Cone NAT or Open Internet.

RE: Contact Header

(OP)
Thank you for responding Critchey,

I have tried most of what you suggested except Static port block.

I will give that a shot and let you know.

Mike

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close