INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Strange Issue with SSIS package - Flat file source does not show the FIRST ROW in preview mode

Strange Issue with SSIS package - Flat file source does not show the FIRST ROW in preview mode

Strange Issue with SSIS package - Flat file source does not show the FIRST ROW in preview mode

(OP)
Dear all,

I have currently facing a strange issue with one of the SSIS packages I am working with.


My SSIS package is the simplest one which is reading from a flat file and writing into a sql table.

the flat file looks like below


The flat file does not have any header name defined.

Now we have created a Flat file connection manager which looks as below








The strange problem is that THE FIRST DATA ROW which is

"2017/02/18","2017","02","18","0023","DB","0026215959 ","ENOTRIA WINECELLARS LTD "," 29,149.09"," 20,000.00","2007/11/03"

is not shown in the preview, and for the same reason when we are loading the data into the table the first line of data is missing.

What could be the reason for this? Is the first data row is some how getting overwritten by the columns we added?

Please help here. I am breaking my head on this for hours still no luck


Thanks in advance.

RE: Strange Issue with SSIS package - Flat file source does not show the FIRST ROW in preview mode

Cross posting on different forums is not quite a good thing.

Post on one forum, and if you don't get a reply in a few days then post on another - not at the same time.

https://www.sqlservercentral.com/Forums/1860910/St...

Answer given on the other forum, which is also visible on the screen shots above is the header flag being set.

Regards

Frederico Fonseca
SysSoft Integrated Ltd
www.syssoft-int.com

FAQ219-2884: How Do I Get Great Answers To my Tek-Tips Questions?
FAQ181-2886: How can I maximize my chances of getting an answer?

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close