INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

GridView caption not rendering

GridView caption not rendering

(OP)
I have a real tough problem. I have an asp.net web page with a couple of gridviews on it. I have caption values set. The caption shows when you are in the designer. When the page is executed there is no caption shown. If I do a "View Page Source", I can see the caption. I have even gone so far as to copy out the entire <div> set from and pasted it into its own .html page and guess what? I can see the caption!

Of course, there are no styles when I do that so I went so far as to modify my markup to not have any styles at all on the gridviews and still no captions.

I am at a loss. I've created a PDF document that shows everything so maybe someone can look at it and provide an idea of what to do.

Thanks in advance,
Jerry

Jerry Scannell

RE: GridView caption not rendering

I looked at your document and as you state, the HTML shows the caption and if you take the HTML and just put it in a standard HTML page you see the caption.
So, I would think you have some CSS that is positioning the grid or something above it over the caption. You should use some browser tools (I use FireBug in FireFox) to inspect the elements on your page. You will see the caption in the raw HTML. From there I would check your CSS

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close