INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Can't display table's content on new platform

Can't display table's content on new platform

(OP)
Hello everyone,
I moved into a new computer and copied databases from the old machine's MySQL databases
located in c:\xampp\mysql\data\dbname to the new machine.
When I tried to show table's content I get an error message that says:
"table dbname.tablename doesnt exist" but when I type: "show tables" it shows up !
Attached is a screenshot shows a folder's content of c:\xampp\mysql\dbname where table
"employers" exists and a screeshot of MySQL interface where table "employers" shows up
when I type: "show tables" but when I type: "select * from employers" I get an error
message says that it doesn't exist !
Can anyone help me with make that table come to life again?
Thanks !

RE: Can't display table's content on new platform

Hi

That dash ( - ) in the table name yells for quoting, so I would try :

CODE --> MySQL

select * from `index-employers` 

Feherke.
feherke.ga

RE: Can't display table's content on new platform

(OP)
Thanks,
It didn't work like I expected because I had another try on a table without a dash at its' name: "Select * from emps" and received an error message that says:
"Table allavdut.emps doesn't exist".

RE: Can't display table's content on new platform

Hi

Maybe there is some special character in that table's name ? Like a trailing whitespace character. Or written with cyrillic e instead of latin e.

I would run mysqldump -Qd allavdut | grep 'CREATE TABLE' and check the exact spelling of that table's name.

Feherke.
feherke.ga

RE: Can't display table's content on new platform

(OP)
I doubt it because I tried many other tables and it all ended the same error. Anyway, I'll try what you wrote, tomorrow.
Thanks a lot

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close