INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Jobs from Indeed

Application Builder "List of Applications not available..."

Application Builder "List of Applications not available..."

(OP)
So Application Builder was set up on my new PC, but I don't think IT set it up completely.
I've located App Builder in my C:/ and can open it up, but in attempting to Create or Open existing applications, I get the error "List of Applications not available on the server"
I think this is because my CallPilot server may not be defined... but I can't figure out where exactly to set that information up (the documentation for the set up and installation I've found says to look at Online Help, but AppBuilder just opens up to an 404 error.
I have also tried opening Application Builder through CallPilot's web UI but AppBuild is not an option in my CallPilot.

After a few hours of trying to figure this out, figured I'd reach out here before calling our 3rd party tech support and getting charged out the @$$.

RE: Application Builder "List of Applications not available..."

I'm not sure if the following below is related to your problem?.

Verify the following TCP and UDP ports are enabled:

TCP port 20 (FTP)
TCP port 21 (FTP)
TCP port 135 (DCOM)
UDP port 135 (DCOM)
TCP port 143 (IMAP)
TCP port 389 (LDAP)
TCP port 636 (LDAP)
TCP port 993 (IMAP)
TCP ports 1024 to 65535 (DCOM)
UDP ports 1024 to 65535 (DCOM)

Not able to connect to AOS server

1. Select start > run > dcomcnfg
2. Select component services > computers > my computer
3. Right-click and select properties
4. Select the General tab and make sure the check box ' *enable DCOM on this computer'* is checked
5. Select the default protocols tab and make sure ' *Connection Oriented TCP/IP*' is selected and is on top of the list.
6. Click Apply and exit out of the dcomcnfg utility.
7. Restart the client pc.


Check the following AOS DCOM permissions are correct:*
1. Open Start->Administrative Tools->Component Service.
2. On the left pane of Component Services go to Component Services->Computers->My Computer->DCOM Config->nmaos.
3. Open Security tab in nmaos properties.
4. Under Launch and Activation Permissions click Customize and then click Edit button.
5. Make sure that ANONYMOUS LOGON group has Local Launch, Local Activation and Remote Activation permissions granted.
6. If not, then add ANONYMOUS LOGON group with Local Launch, Local Activation and Remote Activation permissions granted.
7. If not, correct and reboot.


Check ANONYMOUS LOGON group is permitted*
1. Go to Start -> Programs -> Administrative Tools -> Local Security Policy.
2. On the left pane select Security Settings -> Local Policies -> Security Options.
3. On the right pane find 'DCOM: Machine Launch Restrictions in Security Descriptor Definition Language (SDDL) syntax' line and double click on it.
4. Click Edit Security. Launch Permission window will appear.
5. Make sure that ANONYMOUS LOGON group is granted with Local Launch and Remote Activation permissions. Grant them if necessary by selecting Add, Advanced, Find Now, and double clicking on ANONYMOUS LOGIN, then save your changes.
6. Reboot is not required.


Check the following to get AOS to start in order to login to CPMGR:
1. Run regedit.
2. Under HKKEY_LOCAL_MACHINE->SOFTWARE->NORTEL-> MPCX->NMLDAPSRV.
3. Set EnableLoginAuth to yes.
4. Set EnableCRAuth to yes.
5. Exit regedit.
6. Reboot CP server

Firebird Scrambler

Nortel & Avaya Meridian 1 / Succession & BCM / Norstar Programmer

Website = http://somertel.com

RE: Application Builder "List of Applications not available..."

(OP)
Thank you for your wicked fast reply! I'm going to go through this and give it a try, will update with (hopefully positive) results.

RE: Application Builder "List of Applications not available..."

What is the name of the executable file you are running? When you start Application builder you should get a dialog box to enter your user id and password and then select or add a system. Are you seeing that?

RE: Application Builder "List of Applications not available..."

(OP)
Okay, so that's part of the problem. Now I just need to figure out the information for my the server. Unfortunately it was saved as localhost on the previous machine... so I'll have to figure out what IP address I need

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close