INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

8831 with CME10.5

8831 with CME10.5

(OP)
I am trying to setup my 8831 phone on my CME10.5 4321 router. I know you have to do the fast track mode. I tried a few configs I found online and all seem to end up the same way. My router does not generate the .tlv files (not sure if it is supposed to). It does generate the SEPAC44F214B5E3.cnf.xml according to the tftp-bind however it looks like the phone is looking for a signed version of this file along with other files that do not seem to be generated. My IOS is 15.5 and Im using 9-3-3-5 firmware for the phone (which is never requested by the phone, maybe it is already there not sure) Any and all help greatly appreciated.

Debug errors

*Dec 16 20:54:28.633: TFTP: Server request for port 38653, socket_id 0x7F4CEE4D3F70 for process 128
*Dec 16 20:54:28.633: TFTP: read request from host 192.168.10.1(38653) via GigabitEthernet0/0/0
*Dec 16 20:54:28.633: TFTP: Looking for CTLSEPAC44F214B5E3.tlv
*Dec 16 20:54:28.633: TFTP: Sending error 1 No such file
*Dec 16 20:54:28.947: TFTP: Server request for port 36227, socket_id 0x7F4CEE4D3F70 for process 128
*Dec 16 20:54:28.948: TFTP: read request from host 192.168.10.1(36227) via GigabitEthernet0/0/0
*Dec 16 20:54:28.948: TFTP: Looking for ITLSEPAC44F214B5E3.tlv
*Dec 16 20:54:28.948: TFTP: Sending error 1 No such file
*Dec 16 20:54:29.323: TFTP: Server request for port 56258, socket_id 0x7F4CEE4D3F70 for process 128
*Dec 16 20:54:29.323: TFTP: read request from host 192.168.10.1(56258) via GigabitEthernet0/0/0
*Dec 16 20:54:29.323: TFTP: Looking for ITLFile.tlv
*Dec 16 20:54:29.323: TFTP: Sending error 1 No such file
*Dec 16 20:54:30.460: TFTP: Server request for port 46839, socket_id 0x7F4CEE4D3F70 for process 128
*Dec 16 20:54:30.460: TFTP: read request from host 192.168.10.1(46839) via GigabitEthernet0/0/0
*Dec 16 20:54:30.460: TFTP: Looking for SEPAC44F214B5E3.cnf.xml.sgn
*Dec 16 20:54:30.460: TFTP: Sending error 1 No such file
*Dec 16 20:54:30.960: TFTP: Server request for port 37117, socket_id 0x7F4CEE4D3F70 for process 128
*Dec 16 20:54:30.960: TFTP: read request from host 192.168.10.1(37117) via GigabitEthernet0/0/0
*Dec 16 20:54:30.960: TFTP: Looking for XMLDefault.cnf.xml.sgn
*Dec 16 20:54:30.960: TFTP: Sending error 1 No such file
*Dec 16 20:54:31.833: TFTP: Server request for port 59750, socket_id 0x7F4CEE4D3F70 for process 128
*Dec 16 20:54:31.833: TFTP: read request from host 192.168.10.1(59750) via GigabitEthernet0/0/0
*Dec 16 20:54:31.833: TFTP: Looking for SK72f64050-7ad5-4b47-9bfa-5e9ad9cd4aa9.xml.sgn

Registration error

*Dec 16 20:54:32.040: VOICE_REG_POOL: key(0D5761C900032F54) added to nonce table
*Dec 16 20:54:32.040: VOICE_REG_POOL: Contact doesn't match any pools
*Dec 16 20:54:32.040: VOICE_REG_POOL: No entry for (2271) found in contact table
*Dec 16 20:54:32.040: voice_reg_get_phone_index_from_contact: No contact list
*Dec 16 20:54:32.050: voice_reg_get_reg_expires_timer: no voice register pool found
*Dec 16 20:54:32.051: VOICE_REG_POOL: Register request for (2271) from (192.168.10.1)
*Dec 16 20:54:32.051: auth present

*Dec 16 20:54:32.051: VOICE_REG_POOL: Contact doesn't match any pools
*Dec 16 20:54:32.051: VOICE_REG_POOL: No entry for (2271) found in contact table
*Dec 16 20:54:32.051: voice_reg_get_phone_index_from_contact: No contact list
*Dec 16 20:54:32.061: voice_reg_get_reg_expires_timer: no voice register pool found
*Dec 16 20:54:32.062: VOICE_REG_POOL: Register request for (2271) from (192.168.10.1)
*Dec 16 20:54:32.062: auth present

*Dec 16 20:54:32.062: VOICE_REG_POOL: Contact doesn't match any pools
*Dec 16 20:54:32.062: VOICE_REG_POOL: No entry for (2271) found in contact table
*Dec 16 20:54:32.062: voice_reg_get_phone_index_from_contact: No contact list
*Dec 16 20:54:32.074: voice_reg_get_reg_expires_timer: no voice register pool found
*Dec 16 20:54:32.075: VOICE_REG_POOL: Register request for (2271) from (192.168.10.1)
*Dec 16 20:54:32.075: auth present

*Dec 16 20:54:32.075: VOICE_REG_POOL: Contact doesn't match any pools
*Dec 16 20:54:32.075: VOICE_REG_POOL: No entry for (2271) found in contact table
*Dec 16 20:54:32.075: voice_reg_get_phone_index_from_contact: No contact list
*Dec 16 20:55:40.243: EVENT: 1 node in nonce tree obsolete
*Dec 16 20:55:40.243: VOICE_REG_POOL: deleted key(0D5761C900032F54) from nonce table

My config

!
ip dhcp pool phones
network 192.168.10.0 255.255.255.0
option 150 ip 192.168.10.50
!
!
!
!
!
!
!
!
!
!
subscriber templating
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
sip
registrar server
!
!
!
!
!
voice register pool-type 8831
description Cisco SIP Phone 8831.
reference-pooltype 6921
!
voice register global
mode cme
source-address 192.168.1.99 port 5060
max-dn 10
max-pool 10
load 8831 sip8831.9-3-3-5.loads
authenticate register
create profile sync 000651604352126A
!
voice register dn 9
number 2271
name TEST
!
voice register pool 3
busy-trigger-per-button 1
id mac AC44.F214.B5E3
type 8831
number 1 dn 9
dtmf-relay sip-kpml
username admin password cisco
codec g711ulaw
!
!
!
!
license udi pid ISR4321/K9 sn FDO19510LXM
license accept end user agreement
license boot level uck9
!
spanning-tree extend system-id
!
!
redundancy
mode none
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface GigabitEthernet0/0/0
ip address 192.168.10.50 255.255.255.0
negotiation auto
!
interface GigabitEthernet0/0/1
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
shutdown
negotiation auto
!
interface Vlan1
no ip address
shutdown
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
tftp-server flash:sip8831.9-3-3-5.loads
tftp-server flash:kern8831.9-3-3-5.sebn
tftp-server flash:rootfs8831.9-3-3-5.sebn
tftp-server flash:sboot8831.9-3-3-5.sebn
!
control-plane
!
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

RE: 8831 with CME10.5

(OP)
As an update, defaulting the phone stopped it from looking for a .sgn file. The .tlv files are needed for security, and if the phone does not find them it proceeds on. I still can not get the 8831 registered. I was able to get a 8841 registered using fast track mode just fine, so I know my SIP setup in general is ok and that a very similar fast track setup works. As a last ditch, I am going to try another 8831 and see if maybe the phone is just bad.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close