INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

proxy.pac not working correctly in IE11

proxy.pac not working correctly in IE11

(OP)
I've never quite managed to get a proxy.pac file working 100%. In the past I've just let is slide and some things are sent to the proxy when they should go direct but in my current role that isn't good enough.

I've used http://home.thorsen.pm/proxyforurl and it says all is ok. I've also used AutoProxy command line utility and it again says all is ok. But things that should be sent direct still go to the proxy.

It appears to work fine in Firefox.

IE11 has HKCU\SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\ {REG_DWORD} EnableAutoproxyResultCache set to 0.

My file is pretty simple:

CODE --> javascript

function FindProxyForURL(url, host)
{
	if	(isInNet (dnsResolve(host), "10.26.0.0", "255.255.0.0"))
	return "DIRECT";
		
	else if	(isPlainHostName(host))
	return "DIRECT";
		
	else if	(shExpMatch(url, "*.mydomain.com"))
	return "DIRECT";
		
	else return "PROXY proxy01.mydomain.com:8080"; "PROXY proxy02.mydomain.com:8080";
	
} 
Things like server.mydomain.com still go to the proxy rather than direct. I've tried various combinations of the code (with and without 'else' etc) but nothing changes.

I also found referenes to the PAC file must be in ANSI format, not Unicode, to work in IE but the file is already in ANSI.

Any ideas how to get it to work 100% in IE11?

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close