INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

DB2 11.1 SQL1022C There is not enough memory available to process the command

DB2 11.1 SQL1022C There is not enough memory available to process the command

DB2 11.1 SQL1022C There is not enough memory available to process the command

(OP)
I have windows 7 Professional that is running a vmware Windows 10 Professional. The host machine has 16G RAM, vm RAM 4G (also tried it with 12G), DB2 version 11.1. I am a web programmer and I am not fluent in DB2. I was tasked with setting up a windows 10 vm for developers. The DB2 database is remote on a z/OS 10.1.2 server.

db2licm -l returns the following

Product name: "DB2 Connect Enterprise Edition"
License type: "Client Device"
Expiry date: "Permanent"
Product identifier: "db2consv"
Version information: "11.1"

Although the error returned from the command prompt indicates a memory problem when I look in db2diag.log I can also see a ssl problem. Here is text from the log.


2016-11-07-14.28.42.141000-300 I3166F368 LEVEL: Error
PID : 6340 TID : 892 PROC : db2bp.exe
INSTANCE: DB2 NODE : 000
HOSTNAME: DevMasterWin10
EDUID : 892
FUNCTION: DB2 UDB, common communication, sqlccGetSSLApiAddress, probe:395
MESSAGE : DIA3602E Error getting SSL function address: "pgsk_msgerror".

2016-11-07-14.28.42.208000-300 I3536F343 LEVEL: Error
PID : 6340 TID : 892 PROC : db2bp.exe
INSTANCE: DB2 NODE : 000
HOSTNAME: DevMasterWin10
EDUID : 892
FUNCTION: DB2 UDB, common communication, sqlccLoadSSLLibrary, probe:309
RETCODE : ZRC=0x90000078=-1879048072


2016-11-07-14.28.42.410000-300 I3881F445 LEVEL: Error
PID : 6340 TID : 892 PROC : db2bp.exe
INSTANCE: DB2 NODE : 000
HOSTNAME: DevMasterWin10
EDUID : 892
FUNCTION: DB2 UDB, common communication, sqlccLoadSSLLibrary, probe:309
RETCODE : ZRC=0x00000E12=3602
SQL3602W Check data processing found constraint violations and moved
them to exception tables.


2016-11-07-14.28.42.451000-300 I4328F361 LEVEL: Error
PID : 6340 TID : 892 PROC : db2bp.exe
INSTANCE: DB2 NODE : 000
HOSTNAME: DevMasterWin10
EDUID : 892
FUNCTION: DB2 UDB, common communication, sqlccLoadSSLLibrary, probe:998
MESSAGE : DIA3603E SSL was not setup. Return code = "-1879048072".

2016-11-07-14.28.42.534000-300 I4691F491 LEVEL: Severe
PID : 6340 TID : 892 PROC : db2bp.exe
INSTANCE: DB2 NODE : 000
HOSTNAME: DevMasterWin10
EDUID : 892
FUNCTION: DB2 UDB, DRDA Communication Manager, sqljcCommConnect, probe:10
MESSAGE : ZRC=0x80360053=-2143944621=SQLZ_RC_BDS_INSSYS, SQLT_SQLJC
"Insufficient system resources"
DATA #1 : String, 11 bytes
CCI Error:
DATA #2 : unsigned integer, 8 bytes
120


I am currently using the gsk 32 and 64 bit install files.

Here is what I have done.
The following steps worked for DB2 IBM Data Server Client 9.7 running on server 2008 R2 standard.

1. Logged into VM using the local Administrator account.
2. Installed IBM Data Server Client Version 11.1. Ran setup.exe with run as Administrator. I used the typical install options with one exception. I selected the option to not create a response file.
3. Applied the license file through the elevated DB2 command prompt.
4. Added an entry to the C:\Windows\System32\drivers\etc\services file to allow connection for the DB2 database.
5. Added the following local users to the DB2ADMNS account. IUSR, NETWORK SERVICE, SYSTEM and INTERACTIVE. Typically only the IUSR and NETWORK SERVICE is needed but since I was having problems I added the other two.
6. Installed gsk8ssl32.exe and gsk8crypt32.exe (version 8.0.14.14).
7. Added C:\Program Files\IBM\GSK8\lib64 and C:\Program Files (x86)\IBM\GSK8\lib to the path system environment variables.
8. Rebooted the vm.
9. At the elevated DB2 command prompt I created a key database a stash file. This was done from C:\Program Files (x86)\IBM\GSK8\bin\
10. Through windows explorer I add the local DB2ADMNS group to the stash file located at C:\Program Files (x86)\IBM\GSK8\lib. The permissions are read and read & execute.
11. Added a cert to the key database that is needed for the calls.
12. From the elevated DB2 command prompt I added updated the dbm cfg and applied the kdb file to SSL_CLNT_KEYDB as well as the sth file to the SSL_CLNT_STASH.
13. From the elevated DB2 command prompt I cataloged the tcpip node to sslnode remote and the security is SSL.
14. From the elevated DB2 command prompt I cataloged database with node as sslnode and authentication server.
15. Installed gsk8ssl64.exe and gsk8crypt64.exe (version 8.0.14.14).
16. Through Windows Explorer I ran the odbcad32.exe (as admin) file from the SysWOW64 folder. Then I add a system DSN for the 32 bit.
17. Through Windows Explorer I ran the odbcad32.exe (as admin) file from the System32 folder. Then I add a system DSN. I do get a warning that says "You are logged on with non-Administrative privileges. System DSNs could not be created or modified.". However, I am allowed to continue and add a system DSN for the 64 bit.
18. Through Windows Explorer I ran the odbcad32.exe (as admin) file from the SysWOW64 folder. I selected the 32 bit system DSN and added CLI parameters.
19. Through Windows Explorer I ran the odbcad32.exe (as admin) file from the System folder. I selected the 64 bit system DSN and added CLI parameters. They already existed from step 18 but I went through the steps anyway.
20. Now I go to an elevated DB2 command prompt and attempt to connect to the database. The message at the command prompt is SQL1022C There is not enough memory available to process the command. SQLSTATE=57011.

Please help.

Thanks.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close