INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

OpenSSH error: Algorithm negotiation fail

OpenSSH error: Algorithm negotiation fail

(OP)
Ubuntu Server 16.04 with OpenSSH 7.2 package

I need to dump / upload my phone system backup files to a SFTP server so I setup this Linux machine to receive the files.

When I try and send the files I get this error message:
An error occurred while trying to connect to the sftp server xxx.xxx.xxx.45

My phone system log files show it as this error:
An error occurred while trying to connect to xxx.xxx.xxx.45 with s8800:Algorithm negotiation fail

My SSH log files show the error as this:
Oct 26 16:50:31 localhost sshd[2024]: fatal: Unable to negotiate with xxx.xxx.xxx.56 port 55751: no matching key exchange method found. Their offer: diffie-hellman-group1-sha1,diffie-hellman-group-exchange-sha1 [preauth]

I did some research and I found I needed to add this to my ssh_config file:
KexAlgorithms +diffie-hellman-group1-sha1

Which hasn't made any difference.

Does anyone have any suggestions?

RE: OpenSSH error: Algorithm negotiation fail

(OP)
After I did a lot of research, reading and trial/error I got it figured out.

I needed to add both diffie-hellman lines separately.
Added to my sshd_config file;
"KexAlgorithms +diffie-hellman-group1-sha1"
"KexAlgorithms +diffie-hellman-group-exchange-sha1"
Both lines needed to be added

I still got the "Algorithm negotiation fail" message but I got a different error in my ssh log file.
"no matching cipher found. Their offer: aes128-cbc,3des-cbc,blowfish-cbc [preauth]"

So, I had to add another line to my sshd_config file;
"Ciphers aes128-cbc,3des-cbc,blowfish-cbc"

I'm now uploading my backup files via SFTP to my Ubuntu Server.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close