INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Connectivity Apache HTTPD & Tomcat7 (AJP Connector)

Connectivity Apache HTTPD & Tomcat7 (AJP Connector)

(OP)
Hi,
We are using Tomcat 7.0.42.0, AJP/1.3 with Apache 2.2.21.
Connecting Apache to Tomcat as VirtualHost, The Problem is Apache and Tomcat losing its connection every 20-30 Minutes. Either We have to hit the WebServer URL multiple times or Reboot Apache & Tomcat to resolve the issue for short-time.
Also accessing WebServer URL is very very slow than tomcat URL (Mostly it takes 30-45seconds to load a Page, However same page is loading within 4-5 seconds through Tomcat URL).

I have added tomcat & Apache configurations below, Kindly please help me to resolve this issue.


Tomcat (Server.xml):

CODE -->

<Connector port="9090" protocol="HTTP/1.1"
 connectionTimeout="600000"
 redirectPort="8443"
 URIEncoding="UTF-8" emptySessionPath="true"/>
<Connector port="9009" protocol="AJP/1.3" redirectPort="8443" URIEncoding="UTF-8" connectionTimeout="600000"/> 

Apache (Workers.properties):

CODE -->

worker.list=prod_live_svr
worker.prod_live_svr.type=ajp13

worker.prod_live_svr.host=10.100.0.31
worker.prod_live_svr.port=9009
worker.prod_live_svr.lbfactor=50
worker.prod_live_svr.socket_keepalive=1

worker.prod_live_svr.connection_pool_size=100 
worker.prod_live_svr.connection_pool_minsize=50 
worker.prod_live_svr.connection_pool_timeout=500 


VirtualHost.conf:

CODE -->

<VirtualHost *:80>

ServerName 10.100.0.31


ErrorLog logs/live/http_error.log
RewriteLog logs/live/http_rewrite.log

RewriteEngine on
RewriteCond %{REMOTE_ADDR} !^10\.100\.0\.31$
RewriteRule ^/+$ /sites/  [R,L]

<IfModule rewrite_module>
Options +FollowSymlinks
RewriteEngine	 On

RewriteOptions Inherit
RewriteLog logs/rewrite.log

</IfModule>
JkMount   /*        prod_live_svr

JkOptions +ForwardURICompatUnparsed

</VirtualHost> 

Thanks
Jayaram

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close