INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Router on a stick, router pings internet but sitch does not

Router on a stick, router pings internet but sitch does not

Router on a stick, router pings internet but sitch does not

(OP)
Good morning, and trust me when I say I appreciate any help with this.

Setup -> Cisco 3750 switch, Cisco 2800 Router

-Switch can ping Vlan ip's -> But not the internet (ie - 8.8.8.8)
-Clients get address from DHCP pool
-Router can ping everything

Router config:

Router#sh run
Building configuration...

Current configuration : 1563 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging console
enable password xxxxxxxxx
!
no aaa new-model
no network-clock-participate wic 0
dot11 syslog
!
!
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
!
archive
log config
hidekeys
!
!
controller T1 0/0/0
framing esf
linecode b8zs
!
!
interface FastEthernet0/0
description WAN
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
ip nat inside
no ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1.10
description JEMI
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1.20
description TEST
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 permit 192.168.10.0 0.0.0.255
access-list 1 permit 192.168.20.0 0.0.0.255
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
password xxxxxxxx
login
line vty 5 45
password xxxxxxxxx
login
!
scheduler allocate 20000 1000
!
end


Switch config:
SW1#sh run
Building configuration...

Current configuration : 4819 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname SW1
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxxxxxxxxxxxxxxxxxxx
!
no aaa new-model
switch 2 provision ws-c3750v2-24ps
system mtu routing 1500
vtp mode transparent
ip subnet-zero
ip routing
no ip domain-lookup
ip dhcp use vrf connected
ip dhcp excluded-address 192.168.10.1
!
ip dhcp pool JEMI
network 192.168.10.0 255.255.255.0
default-router 192.168.10.2
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 10
name JEMI
!
vlan 20
name TEST
!
!
!
interface FastEthernet2/0/1
description TRUNK TO ROUTER
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,20
switchport mode trunk
!
!
interface GigabitEthernet2/0/1
!
interface GigabitEthernet2/0/2
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 192.168.10.2 255.255.255.0
no ip route-cache cef
no ip route-cache
no ip mroute-cache
!
interface Vlan20
description TEST ENVIRONMENT
ip address 192.168.20.2 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
!
end


Once again any help/advice is GREATLY appreciated

RE: Router on a stick, router pings internet but sitch does not

You have enabled IPv4 routing on the switch with the command 'ip routing', therefore the command 'ip default-gateway 192.168.10.1' does nothing... You need to add a default-route 'ip route 0.0.0.0 0.0.0.0 192.168.10.1'

Andy

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close