INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

C857 port forwarding help

C857 port forwarding help

(OP)
Hi,

I have cobbled together a config for my 857 that works in the main, internet access from both wireless and wired. I'm trying to port forward to a web server that resides on IP address 192.168.0.12 currently this wireless until I get cabling to that area. Internally Web server responds but access from the Public IP is not working.

Thanks in advance for any tips I have no further ideas.

version 12.4
no service pad
service timestamps debug uptime
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 XXX
!
no aaa new-model
!
resource policy
!
clock timezone PCTime 8
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.254
!
ip dhcp pool LANUSERS
network 192.168.0.0 255.255.255.0
default-router 192.168.0.254
dns-server 203.0.178.191 203.215.29.191
!
!
ip cef
no ip domain lookup
!
!
crypto pki trustpoint TP-self-signed-3983177844
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3983177844
revocation-check none
rsakeypair TP-self-signed-3983177844
!
!
crypto pki certificate chain TP-self-signed-3983177844
certificate self-signed 01
3082023E 308201A7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 33393833 31373738 3434301E 170D3136 30333133 30393135
35315A17 00000000 00000000 30303030 00000000 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 39383331
37373834 3430819F 300D0609 2A864886 F70D0101 00000000 818D0030 81890281
8100E46C 74A4A516 35ECD588 BB520009 298FBC3F 32D0D846 2397DE5E 9CE2A034
1597238C 6DDE471B C955EB93 B9C8A21D F480625D 1A54875C 4A28E8D1 3414494A
BD2BD21C 083E0A9A A020457E B28E8621 00000000 9F7D662D 6CC26734 B31F1FB1
18D315D1 CDA40713 9C6C13BD 679C8775 13266103 4AE50327 4DB44B22 9C566C5F
4D490203 010001A3 66306430 0F060355 1D130101 FF040530 030101FF 30110603
551D1104 0A300882 00000000 74657230 1F060355 1D230418 30168014 5DB0439A
C476C0DB 25A9F4B4 08DFF3AA DF409A41 301D0603 551D0E04 1604145D B0439AC4
76C0DB25 A9F4B408 DFF3AADF 409A4130 0D06092A 00000000 0D010104 05000381
8100AA57 017B2804 CE30D6B2 AAA20F21 D1A029BC 45B92763 C8349F93 E0A45740
1A3AE30A 00000000 65F8C46D 58102B35 08F8E3CC F63ADCCE 0D3128C9 1A16523C
2C898291 5DA1EAE3 00000000 6D34AF27 A327E8E7 56281188 6F8EDAF7 F6B7ACCC
9B10C054 3CF0F2D0 220D206B 164A4C20 C48EA556 EBA61FF2 BFFB7F12 C7DB0AC6 4719
quit
username admin privilege 15 password 7 0XXXX
!
!
!
bridge irb
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5snap
pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
no ip address
!
encryption mode ciphers tkip
!
ssid Pretty_Fly_For_A_Wifi
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii 7 XXXXXXXXXXXXXX
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
no ip address
ip nat inside
ip virtual-reassembly
bridge-group 1
!
interface Dialer0
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname XXX
ppp chap password 7 XXX
ppp ipcp route default
!
interface Dialer1
no ip address
!
interface BVI1
ip address 192.168.0.254 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 0.0.0.0 0.0.0.0 ATM0
!
no ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source list 101 interface Dialer0 overload
ip nat inside source static tcp 192.168.0.12 80 interface Dialer0 80
!
access-list 23 permit 192.168.0.0 0.0.0.255
access-list 101 permit ip 192.168.0.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
no modem enable
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
!
scheduler max-task-time 5000
end

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close