INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

SSRS Parameter dropdown receiving error: Sys.WebForms.PageRequestManagerServer.

SSRS Parameter dropdown receiving error: Sys.WebForms.PageRequestManagerServer.

SSRS Parameter dropdown receiving error: Sys.WebForms.PageRequestManagerServer.

(OP)
Can anyone point me in the right direction on how to either: run only the parameter values that are selected from the drop down to view the report, instead of it running all of the records or how to resolve the below error. I am using a Group By, but still have 67,000 records in the drop down, but I believe it is erroring out, because of it trying to run through so many records, so how can I have it run only the selected records in the dropdown?

The error I get is:

Sys.WebForms.PageRequestManagerServerErrorException:
An unknown error occurred while processing the request on the server. The status code returned from the server was: 500 or I get status code 12019

I receive this error from the Report Server. The report runs fine from Report Manager and Report Builder.

And, I already added these lines to the Report Servers web.config file:

<appSettings>
<add key="aspnet:IgnoreFormActionAttribute" value="true" />
<add key="aspnet:MaxHttpCollectionKeys" value="100000" />
</appSettings>

I also added these lines but had to remove them:
<system.web.extensions>
<scripting>
<scriptResourceHandler enableCompression="false" enableCaching="true"/>
</scripting>
</system.web.extensions>

Gave me an error in the ReportServer page, I get "The Website Cannot Display the Page", so I had to take those lines out.
Any help is appreciated.

My other 2 reports use the same syntax and they do not have any errors (although there are not as many records being returned in those), but this report is causing the error.

I also should add that in the vendor query, if I put Top (1000) after the Select, then I have no issues or errors with running the report.

Let me know what code you would need to help me in figuring out what the issue is.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close