INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Clients not backing up C:\

Clients not backing up C:\

(OP)
Hello,

Server Win2008 X64 R2 / Networker 7.6.4 Client versions have tried 8.0 - 8.2

I have 3 clients, two desktops and one server that will not backup c:\. They will backup other drives like E:\ and F:\ and the :disaster recovery, but not C:\

All the systems are set to ALL Save Sets. I can right click client in Networker Administrator window and select modify, step through the config and all drives are selected there as well.

I can open the recovery console on the client and see c:\ but cannot recover any files. The client reports on the server don't show c:\ backing up either.

Any idea what would cause c:\ not to backup

Thanks,

Joe

RE: Clients not backing up C:\

This could have a bunch of reasons - the most obvious will be that the drive will be excluded using a 'directive'.

But let me ask first whether the backup attempt will be result in a backup error or is it just excluded?
If there is no error reported, verify the behavior as follows:
- Add a small subdirectory like C:\windows\test and on the client run the command: save -s <server> [-b <pool>] C:\windows\test
- If this works run the same command for the parent directory: save -s <server> [-b <pool>] C:\windows
- If this works run the same command for the parent directory: save -s <server> [-b <pool>] C:\

I assume that there is a forgotten, local "directive" file (nsr.dir). If so, rename it and retry.
Do not start an automatic backup (savegrp) before the 'save' command runs successfully.

BTW - on the latest NW versions, NW should inform you when it found a directive.

RE: Clients not backing up C:\

(OP)
Hello,

Tried the idea of backing up C:\windows\test then C:\windows\ then C:\ and that all works fine, but the the daily incremental backup report shows no C:\ being backed up.

The two desktops and server are failing to back up :disaster recovery as well. The log errors point to issue with System Writers, but there is no mention of failing or skipping C:\ drive

The server for whatever reason started backing up it's C:\

Thanks,

Joe



RE: Clients not backing up C:\

Now the story makes sense - C: will not be backed up due to VSS errors. However, AFAIR this was already stated in the error messages with the NW 7 software.
So it is worth to state all error message details next time.

Repairing VSS errors on Windows 2008+ is pretty easy - simply follow this procedure:

Takeown /f %windir%\winsxs\filemaps\* /a
icacls %windir%\winsxs\filemaps\*.* /grant "NT AUTHORITY\SYSTEM:(RX)"
icacls %windir%\winsxs\filemaps\*.* /grant "NT Service\trustedinstaller:(F)"
icacls %windir%\winsxs\filemaps\*.* /grant BUILTIN\Users:(RX)
net stop cryptsvc
net start cryptsvc
net stop nsrexecd
net start nsrexecd

Add these commands in a new script file to be prepared for the next time.
Then login to the client as administrator and run the following commands:

vssadmin list writers to check their status
<execute the new script file>
vssadmin list writers to verify their status

If there are still some in the wrong state, you need to restart the appropriate service(s). See https://support.software.dell.com/de-de/appassure/...
Worst case, restart the client.

Finally you should update the NW software, if possible.

RE: Clients not backing up C:\

(OP)
Hello,

Before running those commands on the Win2008 server I did the following:

icacls %windir%\winsxs\filemaps\* > C:\acls.txt

It cannot find that path. Looking at environment variable, 'windir" is set to c:\windows and the PATH statement is fairly short, so that should not be a problem. If I replace it
with "icacls c:\windows\winsxs\filemaps\* > C:\acls.txt" command runs just fine. Not sure that matters, just seems strange.

Also, vssadmin list writers does not show any errors currently, should I proceed with the commands suggest in previous post?

Also after trying some test recoveries on this server, drives C:, E:, F: that appeared to be backing according to the reports, do not have files available in the networker user console. From the networker user console it appears as if only a few things from all three drives have backed up.

Thanks,

Joe

RE: Clients not backing up C:\

There is no issue running the commands at any time. These will help to 99,9%. If not, the server restart is the most appropriate solution.

Missing entries in the recover window might point to the fact that there was no successful backup in the current backup cycle.
Try to browse an earlier one, known as good.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close