INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

File upload code has stopped working

File upload code has stopped working

(OP)
Hi,
A while back I used the code I found at http://www.tek-tips.com/faqs.cfm?fid=1869 to create a very simple file upload routine.
It worked fine for over a year then suddenly stopped working. It now puts up the error message "File(s) not uploaded" every time.
As far as I can see the code hasn't changed at all.
Anyone got any idea what might have happened here and how I can get it working again?
Many thanks

RE: File upload code has stopped working

Quote:

Anyone got any idea what might have happened here and how I can get it working again?

Anything we can come up with would be a complete and utter guess as it can only be something that has changed on your server, the details of which we are not privy to.

So the only sensible suggestion is ... ... Ask your hosting provider.

Chris.

Indifference will be the downfall of mankind, but who cares?
Time flies like an arrow, however, fruit flies like a banana.
Webmaster Forum

RE: File upload code has stopped working

As Chris wisely stated, your hosting provider may have changed something. If so, the first place I'd look is ASP properties in IIS. If you don't have access to that you can try a very small file and if successful then it could be related to the filesize, that possibly being an IIS parameter.

Dave idea
[http://flashspot.com]

RE: File upload code has stopped working

(OP)
Thanks guys,
I'm just getting ready to celebrate the New Year but I'll check with the provider asap.
All the best for 2016.
Slainte

RE: File upload code has stopped working

(OP)
ChristHirst and ElEye,
I'm back on the case of this wee mystery and it occurred to me that whatever my have happened on the server it's still running the first bit of code in upLoadEnd.asp (the bit that executes Uploader.Upload() and then generates the message "File(s) not uploaded." when the file count equals 0.
Which suggests that the problem is somewhere in upLoadFunctions.asp or that the server doesn't like something about upLoadFunctions.asp.
Does that throw any light on the problem?
Thanks

RE: File upload code has stopped working

Not really.

However:

For the first [educated] guess (from the first post) is permissions to the save location.

The second would depend on whether your version of the script was using hard-coded locations or server.mappath("location")

The third guess would depend on whether, or not, you were using a parent path syntax '../) to go above the vhost root folder path.

Chris.

Indifference will be the downfall of mankind, but who cares?
Time flies like an arrow, however, fruit flies like a banana.
Webmaster Forum

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close