INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Frame Relay Frustration

Frame Relay Frustration

(OP)
Hey guys,

I'm working through several core technologies (T1/E1/ISDN + Frame-relay switching) in my home lab and an going mad trying to understand what's going on with some of my connections. The topology is fairly simple with 4 routers (3 routers connected to a 4th router acting as a frame-relay switch). So I have 2 routers connecting to the FR switch using T1 data and the 3rd is connected using E1 data connections. The E1 FR connections have come up (line up / protocol up) with no errors etc. No matter what I do, I cannot get the T1 data connections up and running. The line is up but protocol is down (

The controllers have the same framing and linecoding is configured the same on both sides (ESF and B8ZS). The serial interfaces are configured with the clock sources on the FR switch interfaces set to internal and each branch router set to line.

There are no line errors, CRCs, slips or anything obvious on the physical side. Loopback tests are clean and I have made and re-made the T1/E1 crossover cables with the right pinouts. Do this is what we've got.

Router 1 (HQ)
=============

network-clock-participate wic 0
network-clock-select 1 T1 0/0/1

isdn switch-type primary-5ess

controller T1 0/0/1
channel-group 1 timeslots 1-24
description Data-PRI-to-PSTN

interface Serial0/0/1:1
description Data-PVC-to-R2-R3
ip address 3.1.3.1 255.255.255.0
encapsulation frame-relay
frame-relay interface-dlci 130
frame-relay interface-dlci 140

HQ-Router#show int s0/0/1:1
Serial0/0/1:1 is up, line protocol is down
Hardware is GT96K Serial
Description: Data-PVC-to-R2-R3
Internet address is 3.1.3.1/24
MTU 1500 bytes, BW 1536 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation FRAME-RELAY, loopback not set
Keepalive set (10 sec)
CRC checking enabled
LMI enq sent 389, LMI stat recvd 0, LMI upd recvd 0, DTE LMI down
LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0
LMI DLCI 1023 LMI type is CISCO frame relay DTE
FR SVC disabled, LAPF state down
Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
Last input never, output 00:00:03, output hang never
Last clearing of "show interface" counters 01:05:02
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1152 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 12 abort
522 packets output, 6852 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
1 carrier transitions
Timeslot(s) Used:1-24, SCC: 1, Transmitter delay is 0 flags


Router 2 (branch 1)
========

network-clock-participate wic 0
network-clock-select 1 T1 0/0/1

isdn switch-type primary-5ess

controller T1 0/0/1
channel-group 1 timeslots 1-24
description Router2-T1-Data

interface Serial0/0/1:1
description Router2-T1-Data
ip address 3.1.3.2 255.255.255.0
encapsulation frame-relay
frame-relay interface-dlci 150

Router2#show interface Serial0/0/1:1
Serial0/0/1:1 is up, line protocol is down
Hardware is GT96K Serial
Description: Router2-T1-Data
Internet address is 3.1.3.2/24
MTU 1500 bytes, BW 1536 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation FRAME-RELAY, loopback not set
Keepalive set (10 sec)
CRC checking enabled
LMI enq sent 417, LMI stat recvd 0, LMI upd recvd 0, DTE LMI down
LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0
LMI DLCI 1023 LMI type is CISCO frame relay DTE
FR SVC disabled, LAPF state down
Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
Last input never, output 00:00:07, output hang never
Last clearing of "show interface" counters 01:09:44
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1152 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 32 abort
558 packets output, 7324 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
1 carrier transitions
Timeslot(s) Used:1-24, SCC: 1, Transmitter delay is 0 flags

Router3 (Branch)
================

network-clock-participate wic 0
no network-clock-participate wic 1

isdn switch-type primary-net5

controller E1 0/0/1
channel-group 1 timeslots 1-31
description Data-PRI-to-PSTN

interface Serial0/0/1:1
description Data-PRI-to-PSTN
ip address 3.1.3.3 255.255.255.0
encapsulation frame-relay
frame-relay interface-dlci 160

Router3-CME#show int Serial0/0/1:1
Serial0/0/1:1 is up, line protocol is up
Hardware is GT96K Serial
Description: Data-PRI-to-PSTN
Internet address is 3.1.3.3/24
MTU 1500 bytes, BW 1984 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation FRAME-RELAY, loopback not set
Keepalive set (10 sec)
CRC checking enabled
LMI enq sent 438, LMI stat recvd 439, LMI upd recvd 0, DTE LMI up
LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0
LMI DLCI 1023 LMI type is CISCO frame relay DTE
FR SVC disabled, LAPF state down
Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
Last input 00:00:07, output 00:00:07, output hang never
Last clearing of "show interface" counters 01:13:15
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1488 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
439 packets input, 6307 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
441 packets output, 5734 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Timeslot(s) Used:1-31, SCC: 1, Transmitter delay is 0 flags


Frame-Relay switch (router)
===========================

network-clock-participate slot 1
network-clock-participate wic 0
network-clock-participate wic 1

isdn switch-type primary-5ess

controller T1 0/1
framing esf
clock source internal
linecode b8zs
channel-group 1 timeslots 1-24
description HQ-T1-Data

interface Serial0/1:1
description Data connection to HQ
no ip address
encapsulation frame-relay
frame-relay intf-type dce
frame-relay route 130 interface Serial0/3:1 160
frame-relay route 140 interface Serial1/1:1 150

PSTN-01#show interface Serial0/1:1
Serial0/1:1 is up, line protocol is down
Hardware is GT96K Serial
Description: Data connection to HQ
MTU 1500 bytes, BW 1344 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation FRAME-RELAY, loopback not set
Keepalive set (10 sec)
CRC checking enabled
LMI enq sent 0, LMI stat recvd 0, LMI upd recvd 0
LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0, DCE LMI down
LMI DLCI 1023 LMI type is CISCO frame relay DCE
FR SVC disabled, LAPF state down
Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
Last input never, output never, output hang never
Last clearing of "show interface" counters 00:26:23
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/0/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1008 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Timeslot(s) Used:1-24, SCC: 1, Transmitter delay is 0 flags



controller E1 0/3
clock source internal
channel-group 1 timeslots 1-31
description Router3-E1-Data

interface Serial0/3:1
description Router3-E1-Data
no ip address
encapsulation frame-relay
no ip mroute-cache
frame-relay intf-type dce
frame-relay route 160 interface Serial0/1:1 130

PSTN-01#show interface Serial0/3:1
Serial0/3:1 is up, line protocol is up
Hardware is GT96K Serial
Description: Router3-E1-Data
MTU 1500 bytes, BW 1984 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation FRAME-RELAY, loopback not set
Keepalive set (10 sec)
CRC checking enabled
LMI enq sent 0, LMI stat recvd 0, LMI upd recvd 0
LMI enq recvd 183, LMI stat sent 183, LMI upd sent 0, DCE LMI up
LMI DLCI 1023 LMI type is CISCO frame relay DCE
FR SVC disabled, LAPF state down
Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
Last input 00:00:08, output 00:00:08, output hang never
Last clearing of "show interface" counters 00:30:38
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1488 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
183 packets input, 2379 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
183 packets output, 2619 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Timeslot(s) Used:1-31, SCC: 3, Transmitter delay is 0 flags


controller T1 1/1
framing esf
clock source internal
linecode b8zs
channel-group 1 timeslots 1-24
description Router2-T1-Data

interface Serial1/1:1
description Router2-T1-Data
ip address 3.1.3.33 255.255.255.0
encapsulation frame-relay
no ip mroute-cache
frame-relay intf-type dce
frame-relay route 150 interface Serial0/1:1 140

PSTN-01#show interface Serial1/1:1
Serial1/1:1 is up, line protocol is down
Hardware is DSX1
Description: Router2-T1-Data
Internet address is 3.1.3.33/24
MTU 1500 bytes, BW 1344 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation FRAME-RELAY, loopback not set
Keepalive set (10 sec)
LMI enq sent 0, LMI stat recvd 0, LMI upd recvd 0
LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0, DCE LMI down
LMI DLCI 1023 LMI type is CISCO frame relay DCE
FR SVC disabled, LAPF state down
Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
Last input never, output never, output hang never
Last clearing of "show interface" counters 00:29:08
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/0/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1008 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions


.......soooo what gives? Anything obvious? Any ideas?

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close