INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Service Status

Service Status

(OP)
I am trying to query a service to get it's state (running, stopped, etc). I am dumping it to a CSV file.

There may be an easier way to do this.

I have it working but when it dumps to the CSV file for status I see:

@{Status=Running}

I just want to see 'Running'.

I thought that I could just trim like I would any string but not the case.

I created a test program of:

CODE -->

$svcIMA = Get-Service IMAService -ComputerName SERVER01 | Select-Object Status
$IMAtrim = $trimtest.TrimStart("@{Status=")
$IMAResult = $IMAtrim.TrimEnd("}")
Write-Host $imaresult 

When I run it I get:

Method invocation failed because
[Selected.System.ServiceProcess.ServiceController] does not contain a method
named 'TrimStart'.
At C:\scripting\trimtest.ps1:6 char:1
+ $IMAtrim = $trimtest.TrimStart("@{Status=")
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (TrimStart:String) [], Runtime
Exception
+ FullyQualifiedErrorId : MethodNotFound

Any ideas anyone ?

RE: Service Status

Try this:

CODE -->

$svcIMA = Get-Service IMAService -ComputerName SERVER01 | Select-Object Status
$status_start = $svcIMA.IndexOf("=") + 1
$status_end = $svcIMA.length - 1
$IMAResult = $svcIMA.substring($status_start,($status_end-$status_start)) 


Light travels faster than sound. That's why some people appear bright until you hear them speak.

RE: Service Status

Hi can you just do this;

CODE -->

$svcIMA = Get-Service spooler | Select-Object Status
$svcIMA.Status 

Running

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close