INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Some missing parameter prompts when Crystal report first opened in Crystal Viewer

Some missing parameter prompts when Crystal report first opened in Crystal Viewer

Some missing parameter prompts when Crystal report first opened in Crystal Viewer

(OP)
Hello. I have created a Crystal report that uses an Oracle function as its datasource.
Here is the function call that is contained in a Command object in the Crystal report file:
select t.* from TABLE(rvx_gtb_voucher('{?ParamType}',{?ResID},'{?EmbarkDateFrom}','{?EmbarkDateTo}','{?Ship}')) t

The report runs correctly in the Crystal Reports software. But our users are running it from Crystal Viewer that is launched from my company's proprietary application. When the report file is first opened from Crystal Viewer, the parameter screen that displays only contains the prompts for the parameters which are text boxes. The two parameters that contains dropdown list values (ParamType and Ship) do not appear.

At this point, if I select to run the report it will display incorrect reports. After that, when I click the refresh button, the parameter screen appears correctly with all 5 parameters and the report behaves correctly going forward.

How can I make the parameter screen correctly display all 5 parameters when the report is first opened? It behaves this way regardless of whether or not default parameter values are stored in the report file.

I have not encountered this problem when the report file is run agains report views or tables.

Please advise. Thank you!

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close