INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Text spliing across document when exporting to Word

Text spliing across document when exporting to Word

(OP)
I have a report with multiple records (1500ish).

I have built a report that pushes data into the report then exports it to Word as an rtf.

Everything looks correct in the report when I preview it on screen

What I need is for the fields to be aligned correctly
Prefix Number Title
Detail

I have put all the text fields tight against the left hand side of the report area and tried adding a margin (left 4cm) but Word seems to be ignoring the margin.

Detail needs to be underneath Title with blank space underneath Prefix and Number.

Detail is set to CanGrow - Yes
Detail can be many 'lines' long

When I use Word 2003 everything is formatted correctly, when I use Word 2007 or higher, and Detail 'grows' because it is multiple lines in length, there are tabs, carriage returns and spaces all over the place pushing the text underneath prefix and number.

How do I get the Detail field to behave the way I want it, i.e. display multiple lines of text underneath Title without additional lines spilling underneath Prefix and Number?

I know nothing about Word, but as it is working in Word 2003 but not higher versions, I am assuming I need to change things in the Report to prevent this issue.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close