INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Lab AAM single server setup problems.

Lab AAM single server setup problems.

(OP)
Hello again all.

I am attempting to install and configure Avaya Aura Messaging 6.3.1 into my lab for learning, however I am having some problems. (I am starting to feel like a regular here)

My System Info / topology.
cm 6.3 (duplicated VM's)
aam 6.3.1 (single server install)
system manager 6.3
session manager 6.3 with sp15

So far I have successfully got the AAM to register to system manager as a sip entity, but I cannot for the life of my figure out why I cannot get the signaling group and trunk groups up in CM. I have read many different documents on configuring and they are all basically the same. I think I am having some issues with my sip registration because I do not see anything happening in traceSM from session manager. I am sure I should be seeing something from CM trying to register.

My trunk is OOS/FE and Signaling group is far-end bypass
Below is some screen shots of CM



******************************************************
CM
Contains: 03.0.124.0
CM Reports as: R016x.03.0.124.0
CM Release String: vcm-016-03.0.124.0
Publication Date: 04 October 2012

UPDATES:
Update ID Status Type Update description
------------------------------- ------------ ------- ---------------------------
03.0.124.0-21904 activated hot fix for shellshock bug
03.0.124.0-22147 activated cold 6.3.10.0-SP10

VMWT-2.6.18-400.AV1-5.5-004 activated hot VMware Tools-VMTSP0004

KERNEL-2.6.18-400.AV1 activated cold KERNEL-KSP03

Platform/Security ID Status Type Update description
------------------------------- ------------ ------- ---------------------------
PLAT-rhel5.3-3019 activated cold RHEL5.3-SSP306

Messaging ID Status Type Update description
------------------------------- ------------ ------- ---------------------------


CM Translation Saved: 2015-11-03 18:47:49

CM License Installed: 2015-11-03 19:15:21

CM Memory Config: Large
************************************************************


AAM
Contains: 03.0.124.0
CM Reports as: S016x.03.0.124.0
CM Release String: vmsg-016-03.0.124.0
Publication Date: 04 October 2012

UPDATES:
Update ID Status Type Update description
------------------------------- ------------ ------- ---------------------------
03.0.124.0-21904 activated hot fix for shellshock bug

VMWT-2.6.18-400.AV2-5.5-005 activated hot VMware Tools-VMTSP0004

KERNEL-2.6.18-400.AV2 activated cold KERNEL-KSP04

Platform/Security ID Status Type Update description
------------------------------- ------------ ------- ---------------------------
PLAT-rhel5.3-3019 activated cold RHEL5.3-SSP306

Messaging ID Status Type Update description
------------------------------- ------------ ------- ---------------------------
MSG-03.0.124.0-321_0103 activated cold MSG 6.3.1 SP 1


Messaging: +-N6.3-62.0--321Cac+Aac+----mad+-

CM Information
Trunk 99

TRUNK GROUP

Group Number: 99 Group Type: sip CDR Reports: y
Group Name: MSG TRUNK COR: 1 TN: 1 TAC: *99
Direction: two-way Outgoing Display? n
Dial Access? n Night Service:
Queue Length: 0
Service Type: tie Auth Code? n
Member Assignment Method: manual
Group Type: sip

TRUNK PARAMETERS

Unicode Name: yes

Redirect On OPTIM Failure: 5000
page 2

SCCAN? n Digital Loss Group: 18
Preferred Minimum Session Refresh Interval(sec): 600

Disconnect Supervision - In? y Out? y


XOIP Treatment: auto Delay Call Setup When Accessed Via IGAR? n





Caller ID for Service Link Call to H.323 1xC: station-extension


Signaling Group 99

SIGNALING GROUP

Group Number: 99 Group Type: sip
IMS Enabled? n Transport Method: tls
Q-SIP? n
IP Video? n Enforce SIPS URI for SRTP? y
Peer Detection Enabled? y Peer Server: Others
Prepend '+' to Outgoing Calling/Alerting/Diverting/Connected Public Numbers? n
Remove '+' from Incoming Called/Calling/Alerting/Diverting/Connected Numbers? y
Alert Incoming SIP Crisis Calls? n
Near-end Node Name: procr Far-end Node Name: msgserver
Near-end Listen Port: 5061 Far-end Listen Port: 5061
Far-end Network Region: 1

Far-end Domain: sip.homebase.com
Bypass If IP Threshold Exceeded? n
Incoming Dialog Loopbacks: eliminate RFC 3389 Comfort Noise? n
DTMF over IP: rtp-payload Direct IP-IP Audio Connections? y
Session Establishment Timer(min): 3 IP Audio Hairpinning? y
Enable Layer 3 Test? y Initial IP-IP Direct Media? n
H.323 Station Outgoing Direct Media? n Alternate Route Timer(sec): 6



RE: Lab AAM single server setup problems.

as a start i would change all the signalling from CM / SM and AAM to TCP.

Their is a requirement for a new TLS license now - so unless you have that, TCP would be the best.

For all devices, the same protocol should be used end to end, so either all TCP or all TLS

thanks

RE: Lab AAM single server setup problems.

(OP)
Previous to your post I switched all back to TCP and still no change in the status. I will play with it more later today but just wanted to update.

RE: Lab AAM single server setup problems.

(OP)
Got it working somewhat.

I changed the sip settings in AAM under Telephony Integration to point to my CM ip address rather then my Session Manager ip address. Still did not work.

Then I noticed that the signaling group had secure sip set to Y at the top of the page, I changed it to N and it worked. I will have to try and switch back to Session manager to see if it works through that now.

RE: Lab AAM single server setup problems.

Do you have a media gateway registered to your lab system?

RE: Lab AAM single server setup problems.

(OP)
Yes there is a gateway registered.

RE: Lab AAM single server setup problems.

(OP)
Update

I have successfully installed and configured my lab in a few different ways with success.

Setup 1
MAS/MSS single solution server - working and connected to either session manager or communications manager

Setup 2
MAS/MSS single solution server with added single application server for limited failover feature sets.

Setup 3
One MSS and One MAS both working and configured.

I wanted to test each of the setups to see how they performed as well as testing fail over situations. Ultimately followed this guide https://downloads.avaya.com/css/P8/documents/10017...
with this video as well https://www.youtube.com/watch?v=e2LUeCyuLTQ
Both helped me, plus a lot of trial and error. Thank the tech gods for Snapshots.

I found I had some issues with my entity links in session manager that was preventing it from working, I did not add correct ports. I also had some issues with CM and my firewall crossing vlans in my test lab. My firewall is PfSense and is a pain in it self sometimes. Thank you for the help.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close