INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

/etc/NetworkManager/system-connections#

/etc/NetworkManager/system-connections#

(OP)
Sorry for putting this thread unde Unix, but I could not find the equivalent for the linux corner here. It is about the following:
I need a hint for my usage of debian wheezy 7.8 (desktop Kernel 3.2.0-4 and Gnome) to finally edit one specific file with nano. It is about choosing one DNS in the network manager. Therefore I read to edit the following file
/etc/NetworkManager/system-connections# Wired connections 1

By typing as root # cat Wired connections 1

there is literally an empty terminal. Looking at it, I already changed the rights with chmod -R, just to be sure it is writable, there still is an empty screen in the root terminal when typing

nano Wired connections 1


It ain't empty, thats for sure.

With gedit I can see what I'd like to change, the following line from the file mentioned above

[ipv4] method=auto dns=123.456.78.90; ignore-auto-dns=true may-fail=false

I want to change

ignore-auto-dns=true

into

ignore-auto-dns=false

But as nano shows me just nothing, cat does the same, I can't figure out how to get it done, without creating much trouble.
Anyone who got a hint how to do this? Thanks in advance. Still looking for clues. And yes, package python-dbus is installed.
Have a little mercy for the missing code-quotes, they did not result in the desired output here, thats why I put them in bold letters. Excuse me.

RE: /etc/NetworkManager/system-connections#

Does the file name really have spaces in it? That works in the Windows world, but under any kind of Unix/Linux, it will give you nothing but headaches.

When you give the command "cat Wired connections 1", the cat command is trying to output three different files, "Wired", "connections", and "1". Since those three files don't exist, it displays nothing. You should be getting an error message though. Or, three error messages.

Try putting single quotes around it...

CODE

cat 'Wired connections 1' 


RE: /etc/NetworkManager/system-connections#

Oh, and here's the Linux thread, but please don't cross post. This thread works too.

Tek-Tips: Linux (server)

RE: /etc/NetworkManager/system-connections#

(OP)
Thanks a lot, single quoting, I understand. Once again for crossing on the unix platform, as I use as well bsd and depending on the machine I am sitting on, that is why I sometimes get crisscrossed myself. Again, thanks a lot.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close