INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Moving .net 2 site to win 2008 server

Moving .net 2 site to win 2008 server

(OP)
I have to move a .net 2 site from win 2003 server to a win 2008 R2 server, due to win 2003 coming to the end of its support life.

I have set up the site on the new 2008 server and have .net 2 installed, but not 3.5 or above. However when I try to open the site in Internet Explorer I'm getting the error

Error Code 0x80070032
Config Error The configuration section 'system.serviceModel' cannot be read because it is missing a section declaration
Config File \\?\C:\Websites\iservice\web.config

The application pool for the website is set to .net 2 and seems to be running ok.

As the website is an exact copy of the one running on win 2003, which is running fine, I'm doubtful this is actually an error in the config file, and having browsed the internet one solution suggested was to install .net 3.5 as well on the 2008 server, even though the application pool for the website is set to 2.0. Doing this does seem to get rid of the error, but then I get another error when running the site


Error code Ox80070021
This configuration section cannot be used at this path. |This happens when the section is locked at a parent level. locking is either by default (overrideModeDefault="Deny") or set explicitly by a location tag with override="Deny" or the legacy allowOverride="false"

Config File: web.config

Config Source
<validation valiudateIntegrateModeConfiguration="false" />
<modules>
<remove name="ScriptModule" />

I can't find any real information on the web on this, and I'm not a network administrator so my expertise on setting up servers is limited. Has anyone encountered this and can advise.

The main problem with looking on the internet is that most people are moving .net 4 sites, whereas, for operation reasons this site has to stay as .net 2, and run on win 2008 server

Hope someone can help
AndyH1

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close