INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Time formula is correct in CR but shows 12:00:00 in CMC

Time formula is correct in CR but shows 12:00:00 in CMC

(OP)

I've tried several ways to convert a number to a time, i.e. 165236 to 4:52 pm. I found some that work in CR without throwing an error but when I publish the report in CMC and run the report all the times show as 12:00:00 am.

I'm using CR 11 and CMC product 14.0.0

Thank you
VE

RE: Time formula is correct in CR but shows 12:00:00 in CMC

What is your conversation formula?

RE: Time formula is correct in CR but shows 12:00:00 in CMC

(OP)

I've tried several that I found, most of them gave errors in crystal, this one is kind of ugly but it works in crystal:

Time(
if len(replace(totext({OVERLOG1.OVTIME}), ",","")) = 1 then "00:00:00"
else
if len(replace(totext({OVERLOG1.OVTIME}), ",","")) = 3 then "00:0" + left(replace(totext({OVERLOG1.OVTIME}), ",",""), 1)+":00"
else
if len(replace(totext({OVERLOG1.OVTIME}), ",","")) = 4 then "00:" + left(replace(totext({OVERLOG1.OVTIME}), ",",""), 2)+":00"
else
if len(replace(totext({OVERLOG1.OVTIME}), ",","")) = 5 then "0" + left(replace(totext({OVERLOG1.OVTIME}), ",",""), 1) + ":"
+ mid(replace(totext({OVERLOG1.OVTIME}), ",",""),2,2)+ ":00"
else

if len(replace(totext({OVERLOG1.OVTIME}), ",","")) = 6 then left(replace(totext({OVERLOG1.OVTIME}), ",",""), 2) + ":"
+ mid(replace(totext({OVERLOG1.OVTIME}), ",",""),3,2)+ ":00"
else totext(time(00,00,00))
)

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close