INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Issue with SendEmail

Issue with SendEmail

(OP)
I have been using sendEmail for sometime now on various unix boxes running sco 5.0.7 this is the first time I have had any issues with sendEmail. I am not sure if the problem is system related (perl) or related to the smtp server connecting to. I have tried the same email credentials on two other boxes (different site from the one failing) and it works just fine.

CODE -->

May 28 15:15:20 loadstar sendEmail[23152]: DEBUG => Connecting to smtp.gmail.com:587
May 28 15:15:21 loadstar sendEmail[23152]: DEBUG => My IP address is: 192.168.1.10
May 28 15:15:21 loadstar sendEmail[23152]: DEBUG => evalSMTPresponse() - Checking for SMTP success or error status in the message: 2
20 mx.google.com ESMTP o1sm2393854yhp.43 - gsmtp
May 28 15:15:21 loadstar sendEmail[23152]: DEBUG => evalSMTPresponse() - Found SMTP success code: 220
May 28 15:15:21 loadstar sendEmail[23152]: SUCCESS => Received:         220 mx.google.com ESMTP o1sm2393854yhp.43 - gsmtp
May 28 15:15:21 loadstar sendEmail[23152]: INFO => Sending:     EHLO myhome.domain
May 28 15:15:21 loadstar sendEmail[23152]: DEBUG => evalSMTPresponse() - Checking for SMTP success or error status in the message: 2
50-mx.google.com at your service, [162.226.84.88], 250-SIZE 35882577, 250-8BITMIME, 250-STARTTLS, 250-ENHANCEDSTATUSCODES, 250-PIPEL
INING, 250-CHUNKING, 250 SMTPUTF8
May 28 15:15:21 loadstar sendEmail[23152]: DEBUG => evalSMTPresponse() - Found SMTP success code: 250
May 28 15:15:21 loadstar sendEmail[23152]: SUCCESS => Received:         250-mx.google.com at your service, [162.226.84.88], 250-SIZE
 35882577, 250-8BITMIME, 250-STARTTLS, 250-ENHANCEDSTATUSCODES, 250-PIPELINING, 250-CHUNKING, 250 SMTPUTF8
May 28 15:15:21 loadstar sendEmail[23152]: DEBUG => The remote SMTP server supports TLS :)
May 28 15:15:21 loadstar sendEmail[23152]: NOTICE => Authentication not supported by the remote SMTP server!
May 28 15:15:21 loadstar sendEmail[23152]: INFO => Sending:     MAIL FROM:<myemail1@gmail.com>
May 28 15:15:21 loadstar sendEmail[23152]: DEBUG => evalSMTPresponse() - Checking for SMTP success or error status in the message: 5
30 5.7.0 Must issue a STARTTLS command first. o1sm2393854yhp.43 - gsmtp
May 28 15:15:21 loadstar sendEmail[23152]: DEBUG => evalSMTPresponse() - Found SMTP error code: 530
May 28 15:15:21 loadstar sendEmail[23152]: ERROR => Received:   530 5.7.0 Must issue a STARTTLS command first. o1sm2393854yhp.43 - g
smtp 

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close