INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Webservice Header Issue ( Authentication required )

Webservice Header Issue ( Authentication required )

(OP)
Dears
I am developing client application to consume webservice, the webservice developer sent me the wsdl file and the sample SOAP request , all look fine for me

the issue that when I am trying to call the webservice it returns an error message ( Authentication Required ) but I am sending the user name and the password in the header as expected.

here is the Sample SOAP

CODE --> XML

<soapenv:Envelope xmlns:fax="http://fax.po.ws.apps.oracle.xxdof/" xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
   <soapenv:Header><wsse:Security soapenv:mustUnderstand="1" xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd" xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd"><wsse:UsernameToken wsu:Id="UsernameToken-5A2B82D9EE5888AE0414252886487322"><wsse:Username>username</wsse:Username><wsse:Password Type="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#PasswordText">password</wsse:Password><wsse:Nonce EncodingType="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-soap-message-security-1.0#Base64Binary">jMqFQqEM30Yp+t3tP+8meg==</wsse:Nonce><wsu:Created>2015-03-02T09:30:48.732Z</wsu:Created></wsse:UsernameToken></wsse:Security></soapenv:Header>
   <soapenv:Body>
      <fax:faxStatus>
         <!--Optional:-->
         <arg0>0</arg0>
         <!--Optional:-->
         <arg1>0</arg1>
         <!--Optional:-->
         <arg2>0</arg2>
         <!--Optional:-->
         <arg3>0</arg3>
         <!--Optional:-->
         <arg4>0</arg4>
         <!--Optional:-->
         <arg5>0</arg5>
      </fax:faxStatus>
   </soapenv:Body>
</soapenv:Envelope> 

and below the request I am sending

CODE --> XML

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" xmlns:u="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">
  <s:Header>
    <o:Security s:mustUnderstand="1" xmlns:o="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd">
      <o:UsernameToken u:Id="uuid-90e0f212-3dc0-4913-96a8-175697d5240d-1" xmlns:u="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">
        <o:Username>username</o:Username>
        <o:Password Type="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#PasswordText">password</o:Password>
        <o:Nonce EncodingType="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-soap-message-security-1.0#Base64Binary">JY+mppXhcmr+Rl/kzURVoYKFKa4=</o:Nonce>
        <u:Created>2015-03-18T09:43:26.248Z</u:Created>
      </o:UsernameToken>
    </o:Security>
  </s:Header>
  <s:Body>
    <faxStatus xmlns="http://fax.po.ws.apps.oracle.xxdof/" xmlns:i="http://www.w3.org/2001/XMLSchema-instance">
      <arg0 xmlns="">0</arg0>
      <arg1 xmlns="">1</arg1>
      <arg2 xmlns="">2</arg2>
      <arg3 xmlns="">3</arg3>
      <arg4 xmlns="">4</arg4>
      <arg5 xmlns="">5</arg5>
    </faxStatus>
  </s:Body>
</s:Envelope> 

Can you please point me what I am missing here,I was not able to find any issue.

thanks

wasim

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close