INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Page skip problem

Page skip problem

(OP)
Wondering whether anyone can help me understanding the page skip problem that I'm acing.
I've a sub report in one of the detail sections. the report print everything fine except where there is no data concerning the table of the sub report. if there is no data then that section should suppress and follow the next section of the detail. however, the next section print in the next page.
I've suppressed option for suppress blank reports. Also checked for keep together.
The sub report has multiple details sections. I need them 50. If I keep only 36 then I don't see page skip problem. But I need all 50 sections.
if there is some data in the table then the report works normal without problems for all 50 sections.

Many Thanks in advance.

RE: Page skip problem

Try checking the suppress blank section for each detail section. I hope that helps.
50 sub reports? That is a lot!

RE: Page skip problem

(OP)
I did checked suppress blank section on all detail sections both in main and sub report. But no luck.
just to correct :50 sections, not sub reports.

RE: Page skip problem

(OP)
Just to update on my own question: I resolved this issue and figured out that it was because suppress (no-dill down) was not checked. I had a conditional formula in there to show only when needed. Having checked this option, all is printing together.

Thank you.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close