INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Vlan on cisco 2621xm...

Vlan on cisco 2621xm...

(OP)
Hi,

I have this config on a cisco 881, but it is broken. I want to know if is it possible to re-create this config on a router Cisco 2621XM with 3 Ethernet interfaces :

Current configuration : 5306 bytes
!
! Last configuration change at 14:24:25 EST Tue Dec 9 2014 by rene
! NVRAM config last updated at 14:49:43 EST Tue Dec 9 2014 by rene
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router-CMRL
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
memory-size iomem 10
clock timezone EST -5
clock summer-time EST recurring 2 Sun Mar 1:59 1 Sun Nov 1:59
!
crypto pki trustpoint TP-self-signed-1299068418
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1299068418
revocation-check none
rsakeypair TP-self-signed-1299068418
!
!
ip source-route
!
!
ip dhcp excluded-address 172.16.100.129 172.16.100.138
!
ip dhcp pool CENTRE
network 172.16.100.128 255.255.255.192
dns-server 142.217.192.9 142.217.192.8 4.2.2.2
!
!
ip cef
no ip domain lookup
no ipv6 cef
!
!
license udi pid CISCO881-K9 sn FGL1519221A
!
!
username yyyy privilege 15 password xxx
username yyyy privilege 15 password xxx

!
!
!
!
!
!
!
!
interface FastEthernet0
description LAN (VLAN 1)
!
interface FastEthernet1
description Connection a CIMCO (VLAN 2)

spanning-tree portfast
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
shutdown
!
interface FastEthernet4
description Internet
ip address outside IP Fixed
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Vlan1
description LAN
ip address 172.16.100.129 255.255.255.192
ip access-group 101 in
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Vlan2
description CIMCO
ip address 172.16.100.33 255.255.255.248
ip access-group 102 in
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
no ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 1 interface FastEthernet4 overload
ip nat inside source static tcp 172.16.100.34 5900 interface FastEthernet4 5900
ip nat inside source static tcp 172.16.100.34 5800 interface FastEthernet4 5800
ip nat inside source static tcp 172.16.100.137 8080 interface FastEthernet4 8080
ip nat inside source static tcp 172.16.100.130 810 interface FastEthernet4 810
ip route 0.0.0.0 0.0.0.0 FastEthernet4
!
access-list 1 permit 172.16.100.32 0.0.0.7
access-list 1 permit 172.16.100.128 0.0.0.63
access-list 1 deny any
access-list 2 permit 172.16.100.128 0.0.0.63
access-list 2 deny any
access-list 101 permit tcp any host 172.16.100.34 eq 5900
access-list 101 deny ip any 172.16.100.32 0.0.0.7
access-list 101 permit ip any any
access-list 102 permit ip any any
no cdp run

!
!
!
!
!
control-plane
!
alias exec c configure terminal
alias exec save copy running-config startup-config
alias exec s sh ip interface brief
alias exec dhcp sh ip dhcp binding
banner motd ^C
-----------------------------------------------------------------
-- --
-- Routeur Centre Multifonctionnel Richard-Lebeau --
-- --
-- Access restreint --
-- Personnes autorisees seulements --
-- --
-----------------------------------------------------------------^C
!
line con 0
logging synchronous
login local
no modem enable
line aux 0
line vty 0 4
access-class 2 in
privilege level 15
logging synchronous
login local
transport input telnet ssh
!
scheduler max-task-time 5000
ntp server 216.93.242.10
ntp server 149.20.54.20
ntp server 66.96.30.35
ntp server 65.182.224.60
end

Thanks for your help

RE: Vlan on cisco 2621xm...

Hi Bizounett,
It's quite easy!Just plug the 2 cables from switch into the the routed interface of the Cisco 2621XM and configure the 2 subnets on the relevant interface.

Best regards

RE: Vlan on cisco 2621xm...

I think the problem here is the lack of Ethernet interfaces on the 2621XM (it has two 10/100 interfaces). You could do it with a VLAN trunk but currently the 881 is using two separate interfaces to link to (I assume?) either two switches or one switch with two VLANs? You would need to create sub-interfaces on the 2621XM and tag them with the VLAN - something like this:

CODE

interface FastEthernet0/1
 description VLAN Trunk
!
interface FastEthernet0/1.10
 description VLAN 10 LAN
 encapsulation dot1q 10
 ip address 172.16.100.129 255.255.255.192
 ip access-group 101 in
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
interface FastEthernet0.1.20
 description VLAN 20 CIMCO
 encapsulation dot1q 20
 ip address 172.16.100.33 255.255.255.248
 ip access-group 102 in
 ip nat inside
 ip virtual-reassembly
! 
You would then need to configure an 802.1q trunk on the attached switch

CODE

interface FastEthernet0/1
 description VLAN Trunk
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
 switchport nonegotiate
! 
And then put the attached hosts in the correct VLANs

CODE

interface FastEthernet0/2
 description Host in VLAN 10
 switchport access vlan 10
!
interface FastEthernet0/3
 description Host in VLAN 20
 switchport access vlan 20
! 

HTH
Andy

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close