INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

887va-K9 - Configuring a Fast Ethernet switch port as a WAN interface with PPPoE

887va-K9 - Configuring a Fast Ethernet switch port as a WAN interface with PPPoE

887va-K9 - Configuring a Fast Ethernet switch port as a WAN interface with PPPoE

(OP)
Hi all, my first post here, this is actually a follow up to thread557-1730859: cable modem on cisco 887va-k9

The OP was having difficulty using an Ethernet Port to connect to the internet as opposed to the ADSL/VDSL port intended for that purpose. Although he did get it working, he didn't post his final working config. I was having the same difficulty, and the Cisco Configuration Professional software doesn't give you the option to configure the router in that way via the GUI

Using some of the config from the aforementioned thread, cross referenced with some other research, I was able to come up with a working configuration. In my example, Fast Ethernet 0 is the LAN port, and Fast Ethernet 3 is the WAN port. DHCP addresses will be given out on the LAN, in the 10.10.10.x range. The WAN port (or more specifically the dialer linked with the WAN port) is configured to obtain it's IP from the ISP. PAP is used for the PPPoE authentication, and NAT is in use between the LAN and the internet. The model router I have is the 887VA-K9

Substitute anything you see in angle brackets with values specific to your connection

Enjoy!

RE: 887va-K9 - Configuring a Fast Ethernet switch port as a WAN interface with PPPoE

(OP)
Current configuration : 4321 bytes
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco887_no1
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
logging buffered 51200 warnings
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-376923471
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-376923471
revocation-check none
rsakeypair TP-self-signed-376923471
!
!
crypto pki certificate chain TP-self-signed-376923471
certificate self-signed 01
30820229 30820192 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 33373639 32333437 31301E17 0D313430 39323531 34313035
365A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3337 36393233
34373130 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
D6C7F8DE 64BC5557 B630EDFA 6CAC3ED6 626EF88A 7472FB3D E18F3868 EDB8259A
AD8B6834 397FFFC3 2FCEDA76 D6E1195D 8FFC690C 1B0A562A 4106D469 F2E9B9C7
4F403F76 29CBA035 2FBC4CC3 733F11B1 CAA5792D 238F416D A57637B5 BEE0994A
60648960 B4826D50 AEADB67C 35C41CDB 00BC6FFF A9F36F14 2A9EF5C8 B543E54F
02030100 01A35330 51300F06 03551D13 0101FF04 05300301 01FF301F 0603551D
23041830 16801493 9463A10E 2DECD87C B36B87CD BEA60082 20E24630 1D060355
1D0E0416 04149394 63A10E2D ECD87CB3 6B87CDBE A6008220 E246300D 06092A86
4886F70D 01010505 00038181 00D34C7D 2B5E03B5 12513E80 CABF71BB BDB79BC0
F61786B4 0D8AE2B2 CB1CBEC1 23AE4B2E D9CDCA0A 158C9714 1635C14E C3596FCD
7F1318A7 D7887906 55A4B8DB 27958B3C 323B97CD 86D4CB7F FD1789F2 24A56DC7
B0D81477 BBCFCFA1 CA9A4806 8B631DEA DC0FE7C0 BFB923DF 6913F3AA 1DDF5375
66B483EE 623245F9 433A7207 29
quit
!
!
!
!
!
!


!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool ccp-pool
import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server <203.97.78.44>
lease 0 2
!
!
!
no ip domain lookup
ip domain name yourdomain.com
ip cef
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
license udi pid C887VA-K9 sn FGL183923HA
!
!
username <router_admin_username> privilege 15 secret 5 ***************************231
!
!
!
!
!
controller VDSL 0
no cdp run
!
!
!
!
!
!
!
!
!
!
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface Ethernet0
no ip address
shutdown
!
interface FastEthernet0
description LAN interface
switchport access vlan 2
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
description WAN interface
switchport access vlan 10
no ip address
!
interface Vlan1
description not used
ip address 192.168.1.1 255.255.255.0
ip tcp adjust-mss 1412
!
interface Vlan2
description LAN
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Vlan10
description WAN
no ip address
ip nat outside
ip virtual-reassembly in
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer0
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username <isp_username> password 0 <isp_password>
ppp ipcp dns request
no cdp enable
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source list 199 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
dialer-list 1 protocol ip permit
!
access-list 23 permit 10.10.10.0 0.0.0.255
access-list 199 permit ip any any
!
control-plane
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
!
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close