INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

RSTP + Stack

RSTP + Stack

(OP)
Hey all,

I have a wired set up, maybe you can help me to understand 2 things.



I have 2 3750X in a stack.

then I have 5 unmanaged switched connected to the stack.

Each unmanaged switched has 2 ports to the 3750X Stack( one to switch 1 and one to switch 2)

I have rapid spanning tree, with the stack as root. 5 Vlans for each unmanaged switched + L3 int vlan for each vlan and lo0 int.

I don't use dynamic routing. Just running unicast and multicast (lo0 is RP).



everything works fine.

1. rapid spanning tree convergence, if i take one of the unmanaged switched. disconnected port 1 to 3750X 1. It takes 30 seconds until the other port starts to forward. when I reconnect it takes 1 second till the original port started to forward.

Is that logical it takes 30 second for RSTP to converge in this type of setup?





2. I have disconnected the stack cables while switches were running. what happened is that every switch run the same configuration still connected to my set up. after a few minutes I got duplicated IP messages on my 2 3750X.

And I was expecting that muticast and unicast will start to drop , but all was still working.

Had full multicast and unicast connectivity over 3 vlans with 2 hosts and multicast streamer source.

Is that logical?



hope you have any ideas or insights.

RE: RSTP + Stack

What kind of spanning-tree is running on the unmanaged switches?
What do the logs on the 3750s say is happening?

With the stack cables gone, there is no more loop, therefore both uplink switchports on the unmanaged switches will be forwarding traffic. You now effectively have two routers on your network. (hence the duplicate IP addresses). However your hosts on the unmanaged switches can only address their frames at one of them, so you have two cases:
- intra-subnet traffic - frames will be addressed directly to the destination host. The unmanaged switches will forward the frames out the uplink port that saw the latest incoming frame from that device, and as your traffic was already running when you broke the stack, most traffic will be using the uplink port to the top stack member. If the destination host is now on the bottom stack member, it won't take long before the unmanaged switch uplink port to the 2nd switch learns the MAC address and the switch starts forwarding frames out the port to find the destination.
- inter-subnet traffic - the hosts ARP table was probably already populated with the MAC address of the top stack member, so they will continue to forward frames to the top stack member, which will then route the packets onto the correct VLAN to the destination host which is either local or on the 2nd stack member switch, via one of the unmanaged switches.


This would only become super-broken if you had VLANs on the 3750s that are not present on the unmanaged switches.

RE: RSTP + Stack

(OP)
Hey,

1. the unmanaged switches do not run STP as far as I know.
2.only log on the 3750 is that stack cable is disconnected and the duplicated IP.

I assume this topology will break eventually, right?

any Idea why STP takes 30 seconds to converge.

RE: RSTP + Stack

My first thought is, what is your purpose for using the unmanaged switch, with a connection between each of the 3750's? This is just asking for issues in my opinion.
Are you trunking to the unmanaged switch, or is just setup as access ports?
Do you have any BPDUGuard or Portfast enabled on the 3750 ports facing the unmanaged switch?


RE: RSTP + Stack

(OP)
Hey,

I have to use the unmanaged switches. Its a requirement. The are access for users and multicast servers.

No bodyguard or port fast . just plain rstp and root switch config on the 3750. No trunks either.

RE: RSTP + Stack

SHow us the switchport config for both of the Cisco ports that link to an unmanaged switch.

RE: RSTP + Stack

(OP)
Here is the config for 2 vlans conecting to unmanaged switches.

interface GigabitEthernet1/0/21
switchport access vlan 11
switchport mode access
!
interface GigabitEthernet1/0/22
switchport access vlan 22
switchport mode access
!
interface GigabitEthernet2/0/21
switchport access vlan 11
switchport mode access
spanning-tree vlan 11 cost 100
!
interface GigabitEthernet2/0/22
switchport access vlan 22
switchport mode access
spanning-tree vlan 22 cost 100

spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 1-4094 priority 24576


Rest of the vlans similar config.

RE: RSTP + Stack

(OP)
Well for STP problem solved with

spanning-tree mode mst
spanning-tree mst configuration
instance 1 vlan 1-4094

spanning-tree mst 1 root primary
spanning-tree mst forward-time 6

This gets me to 17 seconds convergence time.
can tweak more but 17 is good.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close