INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Crystal Reports 2011 - can't get my Sub Reports detail to print on same line as other detail

Crystal Reports 2011 - can't get my Sub Reports detail to print on same line as other detail

Crystal Reports 2011 - can't get my Sub Reports detail to print on same line as other detail

(OP)
I can't get my subreports detail to print (export to excel) on the same line as my container report's detail. It displays correctly when I run it in Crystal but when I export it to Excel, the sub report detail prints on separate rows.

RE: Crystal Reports 2011 - can't get my Sub Reports detail to print on same line as other detail

Have a read of this "old" Crystal Decisions article. http://hosteddocs.ittoolbox.com/ST030504.pdf It explains how to produce Crystal Reports that export neatly to excel. With subreports it is a little more tricky than a "simple" report but it is possible. Make sure you have hidden every section in the subreport you don't need to see. Make sure the subreport is perfectly aligned to the guideline of the column it needs to line up with in the main report. Make sure the first column in the subreport is perfectly aligned to the left hand edge of the subreport. Make sure the gaps between columns in the main and sub reports is as small as possible. I try to make them less than 1 mm.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close