INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Layer 2 issue

Layer 2 issue

(OP)
Layer 2 issue I think.

I have an NNI switch (ex3300) setup bassically as a pass through, L2.

My NNI has all copper ports setup as acces ports and the SFP port set up as a trunk port and
it is a member of all the VLANs. Below is a partial config to illustrate the setup.

The ISP we are servicing is hanging off ge-0/1/0 and is stacking vlan tags, they are
servicing their customer hanging off port ge-0/0/13. The issue is the customer on port ge-0/0/13 can
see the MAC address of ISP off port ge-0/1/0 but the ISP cant see its customer s MAC, and my ex3300 cant see either
MAC address, and no traffic can be passes. However when the ISP turns off QnQ on his Cisco 7200 we all get visibility.

Basically what is wrong w/ my setup. I am at a total loss.

}
}
ge-0/0/13 {
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members v113;
}
}
ge-0/0/13 {
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members v113;
}
ge-0/1/0 {
mtu 1500;
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members all;
}
}



Here is the entire config
## Last commit: 2014-03-14 17:19:59 UTC by trestleadmin
version 12.3R6.6;
system {
host-name EX3300-NNI;
root-authentication {
encrypted-password "$1$6E9ouesc$LlRgC.QgQHIAQAwfU6mcR."; ## SECRET-DATA
}
login {
user trestleadmin {
uid 2012;
class super-user;
authentication {
encrypted-password "$1$ZKI3s0OE$WpMfPMdfz1IGSo1WHREzS1"; ## SECRET-DATA
}
}
}
services {
ssh;
}
syslog {
user * {
any emergency;
}
file messages {
any notice;
authorization info;
}
file interactive-commands {
interactive-commands any;
}
}
}
interfaces {
ge-0/0/0 {
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members v100;
}
}
}
}
ge-0/0/1 {
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members v101;
}
}
}
}
ge-0/0/2 {
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members v102;
}
}
}
}
ge-0/0/3 {
mtu 9216;
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members v103;
}
}
}
}
ge-0/0/4 {
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members v104;
}
}
}
}
ge-0/0/5 {
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members v105;
}
}
}
}
ge-0/0/6 {
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members v106;
}
}
}
}
ge-0/0/7 {
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members v107;
}
}
}
}
ge-0/0/8 {
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members v108;
}
}
}
}
ge-0/0/9 {
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members v109;
}
}
}
}
ge-0/0/10 {
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members v110;
}
}
}
}
ge-0/0/11 {
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members v111;
}
}
}
}
ge-0/0/12 {
description "mother-industries-ny-5680809|Mother Industries|";
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members v112;
}
}
}
}
ge-0/0/13 {
description "Singapore|";
ether-options {
no-auto-negotiation;
link-mode full-duplex;
speed {
100m;
}
}
unit 0 {
family ethernet-switching {
port-mode access;
vlan {
members v113;
}
}

Here show | display set


set version 11.3R1.7
set system host-name EX3300-NNI
set system root-authentication encrypted-password "$1$6E9ouesc$LlRgC.QgQHIAQAwfU6mcR."
set system login user trestleadmin uid 2012
set system login user trestleadmin class super-user
set system login user trestleadmin authentication encrypted-password "$1$ZKI3s0OE$WpMfPMdfz1IGSo1WHREzS1"
set system services ssh
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces ge-0/0/0 unit 0 family ethernet-switching port-mode access
set interfaces ge-0/0/0 unit 0 family ethernet-switching vlan members v100
set interfaces ge-0/0/1 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/0/1 unit 0 family ethernet-switching vlan members v101
set interfaces ge-0/0/2 unit 0 family ethernet-switching port-mode access
set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members v102
set interfaces ge-0/0/3 mtu 9216
set interfaces ge-0/0/3 unit 0 family ethernet-switching port-mode access
set interfaces ge-0/0/3 unit 0 family ethernet-switching vlan members v103
set interfaces ge-0/0/4 unit 0 family ethernet-switching port-mode access
set interfaces ge-0/0/4 unit 0 family ethernet-switching vlan members v104
set interfaces ge-0/0/5 unit 0 family ethernet-switching port-mode access
set interfaces ge-0/0/5 unit 0 family ethernet-switching vlan members v105
set interfaces ge-0/0/6 unit 0 family ethernet-switching port-mode access
set interfaces ge-0/0/6 unit 0 family ethernet-switching vlan members v106
set interfaces ge-0/0/7 unit 0 family ethernet-switching port-mode access
set interfaces ge-0/0/7 unit 0 family ethernet-switching vlan members v107
set interfaces ge-0/0/8 unit 0 family ethernet-switching port-mode access
set interfaces ge-0/0/8 unit 0 family ethernet-switching vlan members v108
set interfaces ge-0/0/9 unit 0 family ethernet-switching port-mode access
set interfaces ge-0/0/9 unit 0 family ethernet-switching vlan members v109
set interfaces ge-0/0/10 unit 0 family ethernet-switching port-mode access
set interfaces ge-0/0/10 unit 0 family ethernet-switching vlan members v110
set interfaces ge-0/0/11 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/0/11 unit 0 family ethernet-switching vlan members v111
set interfaces ge-0/0/12 unit 0 family ethernet-switching port-mode access
set interfaces ge-0/0/12 unit 0 family ethernet-switching vlan members v112
set interfaces ge-0/0/13 unit 0 family ethernet-switching port-mode access
set interfaces ge-0/0/13 unit 0 family ethernet-switching vlan members v113
set interfaces ge-0/0/14 unit 0 family ethernet-switching port-mode access
set interfaces ge-0/0/14 unit 0 family ethernet-switching vlan members v114
set interfaces ge-0/0/15 unit 0 family ethernet-switching port-mode access
set interfaces ge-0/0/15 unit 0 family ethernet-switching vlan members v115
set interfaces ge-0/0/16 unit 0 family ethernet-switching port-mode access
set interfaces ge-0/0/16 unit 0 family ethernet-switching vlan members v116
set interfaces ge-0/0/17 unit 0 family ethernet-switching port-mode access
set interfaces ge-0/0/17 unit 0 family ethernet-switching vlan members v117
set interfaces ge-0/0/18 unit 0 family ethernet-switching port-mode access
set interfaces ge-0/0/18 unit 0 family ethernet-switching vlan members v118
set interfaces ge-0/0/19 unit 0 family ethernet-switching vlan members v119
set interfaces ge-0/0/20 unit 0 family ethernet-switching port-mode access
set interfaces ge-0/0/20 unit 0 family ethernet-switching vlan members v120
set interfaces ge-0/0/21 unit 0 family ethernet-switching
set interfaces ge-0/0/22 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/0/23 unit 0 family ethernet-switching
set interfaces ge-0/1/0 mtu 1500
set interfaces ge-0/1/0 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/1/0 unit 0 family ethernet-switching vlan members all
set interfaces xe-0/1/0 unit 0 family ethernet-switching
set interfaces ge-0/1/1 unit 0 family ethernet-switching
set interfaces xe-0/1/1 unit 0 family ethernet-switching
set interfaces ge-0/1/2 unit 0 family ethernet-switching
set interfaces xe-0/1/2 unit 0 family ethernet-switching
set interfaces ge-0/1/3 unit 0 family ethernet-switching
set interfaces xe-0/1/3 unit 0 family ethernet-switching
set interfaces me0 unit 0 family inet address 10.250.0.15/24
set interfaces vlan unit 112 family inet address 192.168.1.11/24
set interfaces vlan unit 113 family inet
set interfaces vlan unit 500 family inet address 192.18.202.36/29
set protocols igmp-snooping vlan all
set protocols rstp bridge-priority 0
set protocols lldp interface all
set protocols lldp-med interface all
set ethernet-switching-options dot1q-tunneling ether-type 0x8100
set ethernet-switching-options storm-control interface all
set vlans v100 vlan-id 100
set vlans v101 vlan-id 101
set vlans v102 vlan-id 102
set vlans v103 vlan-id 103
set vlans v104 vlan-id 104
set vlans v105 vlan-id 105
set vlans v106 vlan-id 106
set vlans v107 vlan-id 107
set vlans v108 vlan-id 108
set vlans v109 vlan-id 109
set vlans v110 vlan-id 110
set vlans v111 vlan-id 111
set vlans v112 vlan-id 112
set vlans v112 l3-interface vlan.112
set vlans v113 vlan-id 113
set vlans v114 vlan-id 114
set vlans v115 vlan-id 115
set vlans v116 vlan-id 116
set vlans v117 vlan-id 117
set vlans v118 vlan-id 118
set vlans v119 vlan-id 119
set vlans v120 vlan-id 120
{master:0}[edit]
root@EX3300-NNI#

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close