INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Eclipse running slowly

Eclipse running slowly

(OP)
I don't know if it is just my installation or is eclipse really slow.

On a dedicated 1GHz Linux machine
Eclipse takes 50s running on jdk 1.7 (5s for template proposals to appear)
geany takes 6s
codeblocks takes 14s
vi is immediate

On an W7 VM running on a 2GHz machine
Eclipse between 30s and 120s running on jdk 1.6 (5 to 25s for template proposals to appear)
VS2008 takes 3s (VS2005 is the same)
VS2013 takes an incredible 105s! (Probably the same for VS2010 and VS2012)

The latest offering of netbeans appears to be broken (somehow it can't find the JDK even though it is on the path and eclipse can get to it) so I can't try that to compare.

If I'm doing a lot of coding in eclipse, the machine sometimes goes into 100%CPU mode for 2 to 5 minutes. Eclipse is just totally dead until the CPU usage drops. It just eclipse that is really slow/inefficient or is there something I can do about it (other than not use it or getting an SSD/faster machine), eg allocate more memory.

Is it possible to get eclipse in native mode like the way you can run java programs in native mode.

RE: Eclipse running slowly

To increase the memory you can edit eclipse.ini file and change the options there. For example, this is what I have in my machine right now

-Xmn128m
-Xms256m
-Xmx1024m
-Xss4m
-XX:PermSize=256m
-XX:MaxPermSize=512m

An explanation for the parameters can be found here

Eclipse has been growing to become almost an OS, so performance problems can come from many sources but you can try running it with -clean options or maybe a simple reinstall could solve your problem.



Cheers,
Dian

RE: Eclipse running slowly

(OP)
Thanks - I didn't even know there was an ini file that had configurable bits. I'll mess with the params and see if it speeds up.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close